summaryrefslogtreecommitdiffstats
path: root/python/netifaces/netifaces.SlackBuild
diff options
context:
space:
mode:
author Larry Hajali2017-06-04 19:30:04 +0200
committer Willy Sudiarto Raharjo2017-06-06 02:56:43 +0200
commit06735c91626f488bf089329871e851a02f08b8d0 (patch)
treecff1dc3c45f6e0cc6423b040d89bd2cd5b697635 /python/netifaces/netifaces.SlackBuild
parentbfe4ac492b868fdd85f3e514134f04428f29a646 (diff)
downloadslackbuilds-06735c91626f488bf089329871e851a02f08b8d0.tar.gz
python/netifaces: Updated for version 0.10.6
Signed-off-by: Larry Hajali <larryhaja[at]gmail[dot]com>
Diffstat (limited to 'python/netifaces/netifaces.SlackBuild')
-rw-r--r--python/netifaces/netifaces.SlackBuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/python/netifaces/netifaces.SlackBuild b/python/netifaces/netifaces.SlackBuild
index 60acb41e48..0e9626f9bf 100644
--- a/python/netifaces/netifaces.SlackBuild
+++ b/python/netifaces/netifaces.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for netifaces
-# Copyright 2012-2016 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2012-2017 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=netifaces
-VERSION=${VERSION:-0.10.5}
+VERSION=${VERSION:-0.10.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -57,6 +57,10 @@ find -L . \
python setup.py install --root=$PKG
+if [ "${PYTHON3:-no}" == "yes" ]; then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true