summaryrefslogtreecommitdiffstats
path: root/python/mechanize
diff options
context:
space:
mode:
author Larry Hajali2012-02-05 19:15:37 +0100
committer Robby Workman2012-02-05 19:15:37 +0100
commitbc7d3bff6fbe53914797f19912e150a6f876ebbe (patch)
tree798c3ef8997f8423f5fa8d67de52a568533b63e2 /python/mechanize
parent62faa66ee49bd1cf8bcc982b878fedd8878d589b (diff)
downloadslackbuilds-bc7d3bff6fbe53914797f19912e150a6f876ebbe.tar.gz
python/mechanize: Moved from Libraries
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python/mechanize')
-rw-r--r--python/mechanize/README4
-rw-r--r--python/mechanize/mechanize.SlackBuild51
-rw-r--r--python/mechanize/mechanize.info10
-rw-r--r--python/mechanize/slack-desc19
4 files changed, 84 insertions, 0 deletions
diff --git a/python/mechanize/README b/python/mechanize/README
new file mode 100644
index 0000000000..a0a17a2653
--- /dev/null
+++ b/python/mechanize/README
@@ -0,0 +1,4 @@
+Stateful programmatic web browsing in Python, after Andy Lester's
+Perl module WWW::Mechanize.
+
+This requires pysetuptools or distribute.
diff --git a/python/mechanize/mechanize.SlackBuild b/python/mechanize/mechanize.SlackBuild
new file mode 100644
index 0000000000..efea0eeb62
--- /dev/null
+++ b/python/mechanize/mechanize.SlackBuild
@@ -0,0 +1,51 @@
+#!/bin/sh
+# Slackware build script for mechanize
+# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
+
+PRGNAM=mechanize
+VERSION=0.2.5
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG --no-compile
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *.txt docs/* $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/mechanize/mechanize.info b/python/mechanize/mechanize.info
new file mode 100644
index 0000000000..e474177a2f
--- /dev/null
+++ b/python/mechanize/mechanize.info
@@ -0,0 +1,10 @@
+PRGNAM="mechanize"
+VERSION="0.2.5"
+HOMEPAGE="http://wwwsearch.sourceforge.net/mechanize/"
+DOWNLOAD="http://pypi.python.org/packages/source/m/mechanize/mechanize-0.2.5.tar.gz"
+MD5SUM="32657f139fc2fb75bcf193b63b8c60b2"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Larry Hajali"
+EMAIL="larryhaja[at]gmail[dot]com"
+APPROVED="rworkman"
diff --git a/python/mechanize/slack-desc b/python/mechanize/slack-desc
new file mode 100644
index 0000000000..1296ba9546
--- /dev/null
+++ b/python/mechanize/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+mechanize: mechanize (Stateful programmatic web browsing in Python)
+mechanize:
+mechanize: Stateful programmatic web browsing in Python, after Andy Lester's
+mechanize: Perl module WWW::Mechanize.
+mechanize:
+mechanize: Homepage: http://wwwsearch.sourceforge.net/mechanize/
+mechanize:
+mechanize:
+mechanize:
+mechanize:
+mechanize: