summaryrefslogtreecommitdiffstats
path: root/python/kitchen
diff options
context:
space:
mode:
author Tonus2024-01-05 02:14:53 +0100
committer Willy Sudiarto Raharjo2024-01-05 02:56:16 +0100
commit4fd8c013e94947387085cc9ee95bfdea70d666c8 (patch)
tree98e80c98efc003e5e1c629bcf88382883a021c5e /python/kitchen
parentbe83ecbdfe3dbcdaf8f59f8f5e19c8411730e84b (diff)
downloadslackbuilds-4fd8c013e94947387085cc9ee95bfdea70d666c8.tar.gz
python/kitchen: Added (Useful code).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/kitchen')
-rw-r--r--python/kitchen/README18
-rw-r--r--python/kitchen/kitchen.SlackBuild98
-rw-r--r--python/kitchen/kitchen.info10
-rw-r--r--python/kitchen/slack-desc19
4 files changed, 145 insertions, 0 deletions
diff --git a/python/kitchen/README b/python/kitchen/README
new file mode 100644
index 0000000000..138abef114
--- /dev/null
+++ b/python/kitchen/README
@@ -0,0 +1,18 @@
+We’ve all done it. In the process of writing a brand new application
+we’ve discovered that we need a little bit of code that we’ve
+invented before. Perhaps it’s something to handle unicode text.
+Perhaps it’s something to make a bit of python-2.5 code run on
+python-2.3. Whatever it is, it ends up being a tiny bit of code that
+seems too small to worry about pushing into its own module so it sits
+there, a part of your current project, waiting to be cut and pasted
+into your next project. And the next. And the next. And since that
+little bittybit of code proved so useful to you, it’s highly likely
+that it proved useful to someone else as well. Useful enough that
+they’ve written it and copy and pasted it over and over into each of
+their new projects.
+
+Well, no longer! Kitchen aims to pull these small snippets of code
+into a few python modules which you can import and use within your
+project.
+No more copy and paste! Now you can let someone else maintain and
+release these small snippets so that you can get on with your life.
diff --git a/python/kitchen/kitchen.SlackBuild b/python/kitchen/kitchen.SlackBuild
new file mode 100644
index 0000000000..a64c643417
--- /dev/null
+++ b/python/kitchen/kitchen.SlackBuild
@@ -0,0 +1,98 @@
+#!/bin/bash
+
+# Slackware build script for kitchen
+
+# Copyright 2024 Tonus Paris, France
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=kitchen
+VERSION=${VERSION:-1.2.6}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst NEWS.rst HACKING.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/kitchen/kitchen.info b/python/kitchen/kitchen.info
new file mode 100644
index 0000000000..3e620fdf66
--- /dev/null
+++ b/python/kitchen/kitchen.info
@@ -0,0 +1,10 @@
+PRGNAM="kitchen"
+VERSION="1.2.6"
+HOMEPAGE="https://fedorahosted.org/kitchen"
+DOWNLOAD="https://files.pythonhosted.org/packages/d9/ca/3365cb1160533be8c8b57dbfd6502f367d35e30935ee89a003c664740714/kitchen-1.2.6.tar.gz"
+MD5SUM="f9234da506661a6977e4f38101c653a9"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Tonus"
+EMAIL="tonus1@free.fr"
diff --git a/python/kitchen/slack-desc b/python/kitchen/slack-desc
new file mode 100644
index 0000000000..4e72cdcbe5
--- /dev/null
+++ b/python/kitchen/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+kitchen: kitchen (small snippets of code into a few python modules)
+kitchen:
+kitchen:
+kitchen:
+kitchen:
+kitchen:
+kitchen:
+kitchen:
+kitchen:
+kitchen:
+kitchen: