summaryrefslogtreecommitdiffstats
path: root/python/jmespath/jmespath.SlackBuild
diff options
context:
space:
mode:
author Dimitris Zlatanidis2022-06-27 19:55:29 +0200
committer Willy Sudiarto Raharjo2022-07-02 04:55:45 +0200
commit995db3df11c4eb49be8f308a54571081f092d981 (patch)
tree777c817d541e365cd7fda9a4fce95a6b39fa5288 /python/jmespath/jmespath.SlackBuild
parent0beaf842b6f624f843ec3db44cb715aab2d05bd1 (diff)
downloadslackbuilds-995db3df11c4eb49be8f308a54571081f092d981.tar.gz
python/jmespath: Updated for version 1.0.1.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/jmespath/jmespath.SlackBuild')
-rw-r--r--python/jmespath/jmespath.SlackBuild11
1 files changed, 3 insertions, 8 deletions
diff --git a/python/jmespath/jmespath.SlackBuild b/python/jmespath/jmespath.SlackBuild
index de5cd7b670..ce3fec2661 100644
--- a/python/jmespath/jmespath.SlackBuild
+++ b/python/jmespath/jmespath.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for jmespath
-# Copyright 2014-2020 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2022 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=jmespath
-VERSION=${VERSION:-0.10.0}
+VERSION=${VERSION:-1.0.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -79,12 +79,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-
-# Python 3 support.
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true