summaryrefslogtreecommitdiffstats
path: root/python/jellyfish/jellyfish.SlackBuild
diff options
context:
space:
mode:
author fourtysixandtwo2023-09-25 23:58:08 +0200
committer Willy Sudiarto Raharjo2023-09-30 06:16:32 +0200
commit34e9c8dc271a3bbfbaf9aeb7fd69d64a4c840a56 (patch)
tree1c49fb8544ac67f5d133b61b40013fa874608135 /python/jellyfish/jellyfish.SlackBuild
parent297766e678826aaf48fd2d892fcf0686f9618422 (diff)
downloadslackbuilds-34e9c8dc271a3bbfbaf9aeb7fd69d64a4c840a56.tar.gz
python/jellyfish: Updated for version 1.0.1, with fixes.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/jellyfish/jellyfish.SlackBuild')
-rw-r--r--python/jellyfish/jellyfish.SlackBuild9
1 files changed, 3 insertions, 6 deletions
diff --git a/python/jellyfish/jellyfish.SlackBuild b/python/jellyfish/jellyfish.SlackBuild
index 7fd0e39272..1de13269bb 100644
--- a/python/jellyfish/jellyfish.SlackBuild
+++ b/python/jellyfish/jellyfish.SlackBuild
@@ -28,7 +28,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=jellyfish
-VERSION=${VERSION:-1.0.0}
+VERSION=${VERSION:-1.0.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -83,11 +83,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-# patch pyproject.toml to allow maturin 1.x.x version
-patch -Np1 < $CWD/pyproject.toml.patch
-
-# patch Cargo.toml to exclude dist dir and get rid of build warning
-patch -Np1 < $CWD/Cargo.toml.patch
+# patch Cargo.toml to include missing dep when using filtered sources
+patch --no-backup-if-mismatch -Np1 < $CWD/Cargo-toml.patch
# prevent cargo from using the network.
# this only works because we have a vendored sources tarball with