summaryrefslogtreecommitdiffstats
path: root/python/ipython
diff options
context:
space:
mode:
author Matteo Bernardini2022-02-16 18:56:14 +0100
committer Willy Sudiarto Raharjo2022-02-17 06:59:49 +0100
commit2a2cb0157e2959917e306657b76ed82db81771fc (patch)
tree490a9c5136f57a3d0183d3af0fc12e7f5aeb2d38 /python/ipython
parentc030e56b9b18ac31cea1002dbb5467dd12e6512b (diff)
downloadslackbuilds-2a2cb0157e2959917e306657b76ed82db81771fc.tar.gz
python/ipython: Removed (abandoned).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/ipython')
-rw-r--r--python/ipython/README5
-rw-r--r--python/ipython/ipython.SlackBuild92
-rw-r--r--python/ipython/ipython.info10
-rw-r--r--python/ipython/slack-desc19
4 files changed, 0 insertions, 126 deletions
diff --git a/python/ipython/README b/python/ipython/README
deleted file mode 100644
index 3832cc1ea1..0000000000
--- a/python/ipython/README
+++ /dev/null
@@ -1,5 +0,0 @@
-IPython is a replacement shell for Python programming. It offers an
-enhanced Python shell for the terminal.
-
-This package no longer provides IPython notebook functionality. This is
-now provided with the jupyter-notebook and jupyter-ipykernel packages.
diff --git a/python/ipython/ipython.SlackBuild b/python/ipython/ipython.SlackBuild
deleted file mode 100644
index 244ba72078..0000000000
--- a/python/ipython/ipython.SlackBuild
+++ /dev/null
@@ -1,92 +0,0 @@
-#!/bin/bash
-
-# SlackBuild for ipython
-
-# Copyright 2008-2011 Carlos Corbacho <carlos@strangeworlds.co.uk>
-# Copyright 2013-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=ipython
-VERSION=${VERSION:-7.25.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --root="$PKG"
-rm $PKG/usr/bin/iptest*
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mv $PKG/usr/share/man $PKG/usr
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
-# Delete now empty directory
-rm -rf $PKG/usr/share
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp \
- COPYING.rst README.rst \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/ipython/ipython.info b/python/ipython/ipython.info
deleted file mode 100644
index c2c83242fc..0000000000
--- a/python/ipython/ipython.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="ipython"
-VERSION="7.25.0"
-HOMEPAGE="http://ipython.org"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/i/ipython/ipython-7.25.0.tar.gz"
-MD5SUM="c83047b581398490b5d83129da73aa89"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="decorator ipython_genutils python3-jedi python3-pexpect pickleshare python3-prompt_toolkit simplegeneric traitlets backcall"
-MAINTAINER="Benjamin Trigona-Harany"
-EMAIL="slackbuilds@jaxartes.net"
diff --git a/python/ipython/slack-desc b/python/ipython/slack-desc
deleted file mode 100644
index 2f9295b294..0000000000
--- a/python/ipython/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-ipython: ipython (an enhanced Python shell)
-ipython:
-ipython: IPython is a multiplatform project that offers an enhanced Python
-ipython: shell designed for efficient interactive work.
-ipython:
-ipython:
-ipython:
-ipython:
-ipython:
-ipython:
-ipython: