summaryrefslogtreecommitdiffstats
path: root/python/ipython
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2021-04-17 20:45:38 +0200
committer Robby Workman2021-04-18 09:00:24 +0200
commit08b2c99d10df97c8fe29beab02304742be8c1616 (patch)
treea6d07b409c51fc8c9d76787e99466fd7641415ec /python/ipython
parent2de3a2a57e13175ad5a83920bea60e5de857ea85 (diff)
downloadslackbuilds-08b2c99d10df97c8fe29beab02304742be8c1616.tar.gz
python/ipython: Upgraded for version 7.22.0.
Signed-off-by: Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
Diffstat (limited to 'python/ipython')
-rw-r--r--python/ipython/ipython.SlackBuild15
-rw-r--r--python/ipython/ipython.info8
2 files changed, 10 insertions, 13 deletions
diff --git a/python/ipython/ipython.SlackBuild b/python/ipython/ipython.SlackBuild
index c2e72529af..948ed713ca 100644
--- a/python/ipython/ipython.SlackBuild
+++ b/python/ipython/ipython.SlackBuild
@@ -1,9 +1,9 @@
#!/bin/sh
-# SlackBuild for IPython
+# SlackBuild for ipython
# Copyright 2008-2011 Carlos Corbacho <carlos@strangeworlds.co.uk>
-# Copyright 2013-2018 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2013-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,8 +24,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=ipython
-VERSION=${VERSION:-5.8.0}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-7.22.0}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -40,7 +40,6 @@ CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-DOCS=${DOCS:-no}
set -e
@@ -57,15 +56,13 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python2 setup.py install --root="$PKG"
-rm $PKG/usr/bin/ipython
+python3 setup.py install --root="$PKG"
rm $PKG/usr/bin/iptest*
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-mkdir -p $PKG/usr/man/man1
-mv $PKG/usr/share/man/man1/$PRGNAM.1 $PKG/usr/man/man1/${PRGNAM}2.1
+mv $PKG/usr/share/man $PKG/usr
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
diff --git a/python/ipython/ipython.info b/python/ipython/ipython.info
index 9d69ca723f..e83491ee15 100644
--- a/python/ipython/ipython.info
+++ b/python/ipython/ipython.info
@@ -1,10 +1,10 @@
PRGNAM="ipython"
-VERSION="5.8.0"
+VERSION="7.22.0"
HOMEPAGE="http://ipython.org"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/i/ipython/ipython-5.8.0.tar.gz"
-MD5SUM="7014b8824981eef2cb893ea5398d6b8d"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/i/ipython/ipython-7.22.0.tar.gz"
+MD5SUM="852137f493e62e5730a1245cd91e0636"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="decorator jedi pexpect pickleshare prompt_toolkit1 Pygments shutil_get_terminal_size simplegeneric traitlets"
+REQUIRES="decorator ipython_genutils python3-jedi python3-pexpect pickleshare python3-prompt_toolkit simplegeneric traitlets backcall"
MAINTAINER="Benjamin Trigona-Harany"
EMAIL="slackbuilds@jaxartes.net"