summaryrefslogtreecommitdiffstats
path: root/python/ipaddr-py
diff options
context:
space:
mode:
author Robby Workman2021-05-03 04:41:58 +0200
committer Robby Workman2021-05-03 04:41:58 +0200
commit92f61780f5fb3319d25342da34a183cc4cff78b2 (patch)
treede910c0c15ddceafb710442c7fffd40ff6296ace /python/ipaddr-py
parent40b663c93c29279153ede9c108221af4d7e98192 (diff)
downloadslackbuilds-92f61780f5fb3319d25342da34a183cc4cff78b2.tar.gz
python/ipaddr-py: Updated for Slackware 15.0
New code should be using the "ipaddress" code built into python3.
Diffstat (limited to 'python/ipaddr-py')
-rw-r--r--python/ipaddr-py/ipaddr-py.SlackBuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/python/ipaddr-py/ipaddr-py.SlackBuild b/python/ipaddr-py/ipaddr-py.SlackBuild
index 207af468cd..95368fb059 100644
--- a/python/ipaddr-py/ipaddr-py.SlackBuild
+++ b/python/ipaddr-py/ipaddr-py.SlackBuild
@@ -31,7 +31,7 @@ SRCNAM=ipaddr
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -42,8 +42,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -71,7 +71,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-python setup.py install --root=$PKG
+2to3 -w ipaddr.py
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true