summaryrefslogtreecommitdiffstats
path: root/python/httplib2
diff options
context:
space:
mode:
author Matteo Bernardini2012-09-07 21:50:42 +0200
committer Robby Workman2012-09-09 00:28:32 +0200
commit5522ea241c2ad65c41fb3b3fe22263ed9bdfefe8 (patch)
treedf41a2715958281a1ae75ba3777f490a4abbf3ab /python/httplib2
parentbac40cd03a7cecd9bc5b1c64eec221c80c6d75f8 (diff)
downloadslackbuilds-5522ea241c2ad65c41fb3b3fe22263ed9bdfefe8.tar.gz
python/httplib2: Added (python http library).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'python/httplib2')
-rw-r--r--python/httplib2/README4
-rw-r--r--python/httplib2/httplib2.SlackBuild86
-rw-r--r--python/httplib2/httplib2.info10
-rw-r--r--python/httplib2/slack-desc19
4 files changed, 119 insertions, 0 deletions
diff --git a/python/httplib2/README b/python/httplib2/README
new file mode 100644
index 0000000000..ea01386167
--- /dev/null
+++ b/python/httplib2/README
@@ -0,0 +1,4 @@
+httplib2 (python http library)
+
+A comprehensive HTTP client library that supports many features
+left out of other HTTP libraries.
diff --git a/python/httplib2/httplib2.SlackBuild b/python/httplib2/httplib2.SlackBuild
new file mode 100644
index 0000000000..435e6fb8b7
--- /dev/null
+++ b/python/httplib2/httplib2.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for httplib2
+# Copyright Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy, 2012
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=httplib2
+VERSION=${VERSION:-0.7.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+DOCS="CHANGELOG README"
+
+set -e # Exit on most errors
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/httplib2/httplib2.info b/python/httplib2/httplib2.info
new file mode 100644
index 0000000000..4afda88a44
--- /dev/null
+++ b/python/httplib2/httplib2.info
@@ -0,0 +1,10 @@
+PRGNAM="httplib2"
+VERSION="0.7.4"
+HOMEPAGE="https://code.google.com/p/httplib2/"
+DOWNLOAD="http://httplib2.googlecode.com/files/httplib2-0.7.4.tar.gz"
+MD5SUM="9501be67448bf8f673ad3f68e6d3cd22"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Matteo Bernardini"
+EMAIL="ponce@slackbuilds.org"
diff --git a/python/httplib2/slack-desc b/python/httplib2/slack-desc
new file mode 100644
index 0000000000..525dca1ffe
--- /dev/null
+++ b/python/httplib2/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+httplib2: httplib2 (python http library)
+httplib2:
+httplib2: A comprehensive HTTP client library that supports many features
+httplib2: left out of other HTTP libraries.
+httplib2:
+httplib2: homepage: https://code.google.com/p/httplib2/
+httplib2:
+httplib2:
+httplib2:
+httplib2:
+httplib2: