summaryrefslogtreecommitdiffstats
path: root/python/httplib2
diff options
context:
space:
mode:
author Matteo Bernardini2013-11-14 20:49:47 +0100
committer Robby Workman2013-11-14 21:32:19 +0100
commit1a012f5fdbd37a34667349c67689278adc6073c5 (patch)
tree960ab7e32b0671ff9f92f4b5f3592bf8dc43ba4b /python/httplib2
parent978c334303a05b5f580f49c357eb1019e94fc0fa (diff)
downloadslackbuilds-1a012f5fdbd37a34667349c67689278adc6073c5.tar.gz
python/httplib2: Fixed file permissions.
Thanks to T Stefanov Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'python/httplib2')
-rw-r--r--python/httplib2/httplib2.SlackBuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/python/httplib2/httplib2.SlackBuild b/python/httplib2/httplib2.SlackBuild
index e9b2e98149..c08ec84928 100644
--- a/python/httplib2/httplib2.SlackBuild
+++ b/python/httplib2/httplib2.SlackBuild
@@ -23,7 +23,7 @@
PRGNAM=httplib2
VERSION=${VERSION:-0.8}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -64,11 +64,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG