summaryrefslogtreecommitdiffstats
path: root/python/httplib2/use_system_cacerts.patch
diff options
context:
space:
mode:
author Larry Hajali2014-02-10 16:17:10 +0100
committer Erik Hanson2014-02-11 19:14:56 +0100
commit89e6f2c4c43bb932c44fcd97fd7db45b1dce13fc (patch)
tree9ddc53fd384d967ee355d7dc11a83e6ce7c25ebd /python/httplib2/use_system_cacerts.patch
parent8f3e79a5b786d141bbdf37543bd1bfc5b747a91b (diff)
downloadslackbuilds-89e6f2c4c43bb932c44fcd97fd7db45b1dce13fc.tar.gz
python/httplib2: Added patches for ssl.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'python/httplib2/use_system_cacerts.patch')
-rw-r--r--python/httplib2/use_system_cacerts.patch49
1 files changed, 49 insertions, 0 deletions
diff --git a/python/httplib2/use_system_cacerts.patch b/python/httplib2/use_system_cacerts.patch
new file mode 100644
index 0000000000..d2def9dad8
--- /dev/null
+++ b/python/httplib2/use_system_cacerts.patch
@@ -0,0 +1,49 @@
+Description: Use system ca certificates, not the bundled ones
+Author: Marc Deslauriers <marc.deslauriers@canonical.com>
+Forwarded: not-needed
+Bug-Ubuntu: https://launchpad.net/bugs/882027
+
+Index: b/python2/httplib2/__init__.py
+===================================================================
+--- a/python2/httplib2/__init__.py 2013-03-18 22:37:43.423868573 +0100
++++ b/python2/httplib2/__init__.py 2013-03-18 22:37:43.419868572 +0100
+@@ -190,9 +190,8 @@
+ import ca_certs_locater
+ CA_CERTS = ca_certs_locater.get()
+ except ImportError:
+- # Default CA certificates file bundled with httplib2.
+- CA_CERTS = os.path.join(
+- os.path.dirname(os.path.abspath(__file__ )), "cacerts.txt")
++ # Use system CA certificates
++ CA_CERTS = "/etc/ssl/certs/ca-certificates.crt"
+
+ # Which headers are hop-by-hop headers by default
+ HOP_BY_HOP = ['connection', 'keep-alive', 'proxy-authenticate', 'proxy-authorization', 'te', 'trailers', 'transfer-encoding', 'upgrade']
+Index: b/python3/httplib2/__init__.py
+===================================================================
+--- a/python3/httplib2/__init__.py 2013-03-18 22:37:43.423868573 +0100
++++ b/python3/httplib2/__init__.py 2013-03-18 22:37:43.419868572 +0100
+@@ -123,9 +123,8 @@
+ # Which headers are hop-by-hop headers by default
+ HOP_BY_HOP = ['connection', 'keep-alive', 'proxy-authenticate', 'proxy-authorization', 'te', 'trailers', 'transfer-encoding', 'upgrade']
+
+-# Default CA certificates file bundled with httplib2.
+-CA_CERTS = os.path.join(
+- os.path.dirname(os.path.abspath(__file__ )), "cacerts.txt")
++# Use system CA certificates
++CA_CERTS = "/etc/ssl/certs/ca-certificates.crt"
+
+ def _get_end2end_headers(response):
+ hopbyhop = list(HOP_BY_HOP)
+Index: b/setup.py
+===================================================================
+--- a/setup.py 2013-03-18 22:37:43.423868573 +0100
++++ b/setup.py 2013-03-18 22:37:43.419868572 +0100
+@@ -62,7 +62,6 @@
+ """,
+ package_dir=pkgdir,
+ packages=['httplib2'],
+- package_data={'httplib2': ['*.txt']},
+ classifiers=[
+ 'Development Status :: 4 - Beta',
+ 'Environment :: Web Environment',