summaryrefslogtreecommitdiffstats
path: root/python/git-fame
diff options
context:
space:
mode:
author Andrew Clemons2017-06-12 17:05:56 +0200
committer Willy Sudiarto Raharjo2017-06-15 13:35:55 +0200
commit7eb3bc7cd808870e1a293401f21a2fc5a98c3de2 (patch)
tree75cb0048dc44731966016e98818f7bcd5216263f /python/git-fame
parent0a5a84f7dcd3d9feae3819e4a9026ffb723e8843 (diff)
downloadslackbuilds-7eb3bc7cd808870e1a293401f21a2fc5a98c3de2.tar.gz
python/git-fame: Added (Pretty-print git repository collaborators).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python/git-fame')
-rw-r--r--python/git-fame/README2
-rw-r--r--python/git-fame/git-fame.SlackBuild90
-rw-r--r--python/git-fame/git-fame.info10
-rw-r--r--python/git-fame/slack-desc19
4 files changed, 121 insertions, 0 deletions
diff --git a/python/git-fame/README b/python/git-fame/README
new file mode 100644
index 0000000000..44f6c6b16c
--- /dev/null
+++ b/python/git-fame/README
@@ -0,0 +1,2 @@
+git-fame - Pretty-print git repository collaborators sorted by
+contributions.
diff --git a/python/git-fame/git-fame.SlackBuild b/python/git-fame/git-fame.SlackBuild
new file mode 100644
index 0000000000..67301b50e1
--- /dev/null
+++ b/python/git-fame/git-fame.SlackBuild
@@ -0,0 +1,90 @@
+#!/bin/sh
+
+# Slackware build script for git-fame
+
+# Copyright 2017 Andrew Clemons, Wellington New Zealand
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=git-fame
+VERSION=${VERSION:-1.2.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/etc/bash_completion.d/
+cp git-fame_completion.bash $PKG/etc/bash_completion.d/
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/git-fame/git-fame.info b/python/git-fame/git-fame.info
new file mode 100644
index 0000000000..053b211c79
--- /dev/null
+++ b/python/git-fame/git-fame.info
@@ -0,0 +1,10 @@
+PRGNAM="git-fame"
+VERSION="1.2.0"
+HOMEPAGE="https://pypi.python.org/pypi/git-fame"
+DOWNLOAD="https://pypi.python.org/packages/a1/94/c1ca6b6971e8ae95e713c0dd754e56d335f7a5737b1dd0509ca6d66fdfae/git-fame-1.2.0.tar.gz"
+MD5SUM="3848f7bd4dba574f462b563c3995e51b"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="docopt tqdm"
+MAINTAINER="Andrew Clemons"
+EMAIL="andrew.clemons@gmail.com"
diff --git a/python/git-fame/slack-desc b/python/git-fame/slack-desc
new file mode 100644
index 0000000000..76036ade78
--- /dev/null
+++ b/python/git-fame/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+git-fame: git-fame (Pretty-print git repository collaborators)
+git-fame:
+git-fame: Pretty-print git repository collaborators sorted by contributions.
+git-fame:
+git-fame: https://pypi.python.org/pypi/git-fame
+git-fame:
+git-fame:
+git-fame:
+git-fame:
+git-fame:
+git-fame: