summaryrefslogtreecommitdiffstats
path: root/python/filechunkio
diff options
context:
space:
mode:
author Larry Hajali2012-05-13 15:09:46 +0200
committer dsomero2012-05-13 15:09:46 +0200
commit3d34f836d0088c055c74b67c5b9af81e9db8c9b2 (patch)
tree16548e06009ad5b3f13893b04fec36fd16e61022 /python/filechunkio
parentdf58a6966ae98a47f3ccfd2399daa91593c4fbc6 (diff)
downloadslackbuilds-3d34f836d0088c055c74b67c5b9af81e9db8c9b2.tar.gz
python/filechunkio: Added (upload huge files to Amazon S3)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'python/filechunkio')
-rw-r--r--python/filechunkio/README3
-rw-r--r--python/filechunkio/filechunkio.SlackBuild53
-rw-r--r--python/filechunkio/filechunkio.info10
-rw-r--r--python/filechunkio/slack-desc19
4 files changed, 85 insertions, 0 deletions
diff --git a/python/filechunkio/README b/python/filechunkio/README
new file mode 100644
index 0000000000..ff5f847a24
--- /dev/null
+++ b/python/filechunkio/README
@@ -0,0 +1,3 @@
+FileChunkIO is a way to upload huge files to Amazon S3 in multiple parts without
+having to split them physically upfront (which requires more time and twice the
+disk space) or creating in-memory chunks as StringIO instances.
diff --git a/python/filechunkio/filechunkio.SlackBuild b/python/filechunkio/filechunkio.SlackBuild
new file mode 100644
index 0000000000..3b764cedc7
--- /dev/null
+++ b/python/filechunkio/filechunkio.SlackBuild
@@ -0,0 +1,53 @@
+#!/bin/sh
+
+# Slackware build script for filechunkio
+
+# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
+
+PRGNAM=filechunkio
+VERSION=${VERSION:-1.5}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a PKG-INFO README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/filechunkio/filechunkio.info b/python/filechunkio/filechunkio.info
new file mode 100644
index 0000000000..9cfe11d27f
--- /dev/null
+++ b/python/filechunkio/filechunkio.info
@@ -0,0 +1,10 @@
+PRGNAM="filechunkio"
+VERSION="1.5"
+HOMEPAGE="https://bitbucket.org/fabian/filechunkio"
+DOWNLOAD="http://pypi.python.org/packages/source/f/filechunkio/filechunkio-1.5.tar.gz"
+MD5SUM="bdc8507116dc32c7f140ff76cfd09ecc"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Larry Hajali"
+EMAIL="larryhaja[at]gmail[dot]com"
+APPROVED="dsomero"
diff --git a/python/filechunkio/slack-desc b/python/filechunkio/slack-desc
new file mode 100644
index 0000000000..5d197a23a5
--- /dev/null
+++ b/python/filechunkio/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+filechunkio: filechunkio (upload huge files to Amazon S3)
+filechunkio:
+filechunkio: FileChunkIO is a way to upload huge files to Amazon S3 in multiple
+filechunkio: parts without having to split them physically upfront (which requires
+filechunkio: more time and twice the disk space) or creating in-memory chunks as
+filechunkio: StringIO instances.
+filechunkio:
+filechunkio: Homepage: https://bitbucket.org/fabian/filechunkio
+filechunkio:
+filechunkio:
+filechunkio: