summaryrefslogtreecommitdiffstats
path: root/python/dulwich
diff options
context:
space:
mode:
author Audrius Kažukauskas2011-07-03 19:53:05 +0200
committer Niels Horn2011-07-15 02:54:02 +0200
commit764dcb92d1b2878de7254ddff36dac39119548e6 (patch)
treeef7eabd69e43ef9c99f130bf9eb1f8df56f84659 /python/dulwich
parent764009e81fd8970993da7671be5520b364f0c29f (diff)
downloadslackbuilds-764dcb92d1b2878de7254ddff36dac39119548e6.tar.gz
python/dulwich: Added (implementation of Git formats and protocols)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'python/dulwich')
-rw-r--r--python/dulwich/README5
-rw-r--r--python/dulwich/dulwich.SlackBuild52
-rw-r--r--python/dulwich/dulwich.info10
-rw-r--r--python/dulwich/slack-desc19
4 files changed, 86 insertions, 0 deletions
diff --git a/python/dulwich/README b/python/dulwich/README
new file mode 100644
index 0000000000..20d529eb3f
--- /dev/null
+++ b/python/dulwich/README
@@ -0,0 +1,5 @@
+Dulwich is a Python implementation of the Git file formats and
+protocols. It aims to give an interface to git repos (both local and
+remote) that doesn't call out to git directly but instead uses pure
+Python.
+
diff --git a/python/dulwich/dulwich.SlackBuild b/python/dulwich/dulwich.SlackBuild
new file mode 100644
index 0000000000..a464d61afa
--- /dev/null
+++ b/python/dulwich/dulwich.SlackBuild
@@ -0,0 +1,52 @@
+#!/bin/sh
+
+# Slackware build script for dulwich
+# Written by Audrius Kažukauskas <audrius@neutrino.lt>
+
+PRGNAM=dulwich
+VERSION=${VERSION:-0.7.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -eu
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING HACKING NEWS README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/dulwich/dulwich.info b/python/dulwich/dulwich.info
new file mode 100644
index 0000000000..c8562cd75d
--- /dev/null
+++ b/python/dulwich/dulwich.info
@@ -0,0 +1,10 @@
+PRGNAM="dulwich"
+VERSION="0.7.1"
+HOMEPAGE="http://samba.org/~jelmer/dulwich/"
+DOWNLOAD="http://samba.org/~jelmer/dulwich/dulwich-0.7.1.tar.gz"
+MD5SUM="ee1713c574146735490c229cdef5375e"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Audrius Kažukauskas"
+EMAIL="audrius@neutrino.lt"
+APPROVED="dsomero"
diff --git a/python/dulwich/slack-desc b/python/dulwich/slack-desc
new file mode 100644
index 0000000000..f43f5455a7
--- /dev/null
+++ b/python/dulwich/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+dulwich: dulwich (Python implementation of Git formats and protocols)
+dulwich:
+dulwich: Dulwich is a Python implementation of the Git file formats and
+dulwich: protocols. It aims to give an interface to git repos (both local and
+dulwich: remote) that doesn't call out to git directly but instead uses pure
+dulwich: Python. The project is named after the village in which Mr. and
+dulwich: Mrs. Git live in the Monty Python sketch.
+dulwich:
+dulwich: Homepage: http://samba.org/~jelmer/dulwich/
+dulwich:
+dulwich: