summaryrefslogtreecommitdiffstats
path: root/python/cx_Freeze
diff options
context:
space:
mode:
author Vincent Batts2011-11-08 01:31:05 +0100
committer Robby Workman2011-11-26 16:08:06 +0100
commit278bd97c4d40dba73fe04e8cc5cda939be7ee710 (patch)
treea9b1d8652e3d681fd713f8a93801db5eef97b791 /python/cx_Freeze
parent3ad58f21f5e608c80e2475dfe93f43418088471c (diff)
downloadslackbuilds-278bd97c4d40dba73fe04e8cc5cda939be7ee710.tar.gz
python/cx_Freeze: Added (python script freezer)
Signed-off-by: Erik Hanson <erik@slackbuilds.org>
Diffstat (limited to 'python/cx_Freeze')
-rw-r--r--python/cx_Freeze/README6
-rw-r--r--python/cx_Freeze/cx_Freeze.SlackBuild89
-rw-r--r--python/cx_Freeze/cx_Freeze.info10
-rw-r--r--python/cx_Freeze/slack-desc19
4 files changed, 124 insertions, 0 deletions
diff --git a/python/cx_Freeze/README b/python/cx_Freeze/README
new file mode 100644
index 0000000000..dcc51609c7
--- /dev/null
+++ b/python/cx_Freeze/README
@@ -0,0 +1,6 @@
+cx_Freeze (python script freezer)
+
+cx_Freeze is a set of scripts and modules for freezing Python
+scripts into executables in much the same way that py2exe and py2app
+do. Unlike these two tools, cx_Freeze is cross platform and should
+work on any platform that Python itself works on.
diff --git a/python/cx_Freeze/cx_Freeze.SlackBuild b/python/cx_Freeze/cx_Freeze.SlackBuild
new file mode 100644
index 0000000000..91191185c5
--- /dev/null
+++ b/python/cx_Freeze/cx_Freeze.SlackBuild
@@ -0,0 +1,89 @@
+#!/bin/sh
+
+# Slackware build script for cx_Freeze
+
+# Written by Vincent Batts, vbatts@hashbangbash.com
+
+# Copyright 2011 Vincent Batts, Vienna, VA, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=cx_Freeze
+VERSION=${VERSION:-4.2.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ README.txt HISTORY.txt LICENSE.txt doc/cx_Freeze.html samples/ \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/cx_Freeze/cx_Freeze.info b/python/cx_Freeze/cx_Freeze.info
new file mode 100644
index 0000000000..1c5d373b17
--- /dev/null
+++ b/python/cx_Freeze/cx_Freeze.info
@@ -0,0 +1,10 @@
+PRGNAM="cx_Freeze"
+VERSION="4.2.3"
+HOMEPAGE="http://cx-freeze.sourceforge.net/"
+DOWNLOAD="http://downloads.sourceforge.net/project/cx-freeze/4.2.3/cx_Freeze-4.2.3.tar.gz"
+MD5SUM="a524cfd23de5d37e0ec9400ba1ccd6ad"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Vincent Batts"
+EMAIL="vbatts@hashbangbash.com"
+APPROVED="Erik Hanson"
diff --git a/python/cx_Freeze/slack-desc b/python/cx_Freeze/slack-desc
new file mode 100644
index 0000000000..6531f68c63
--- /dev/null
+++ b/python/cx_Freeze/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+cx_Freeze: cx_Freeze (python script freezer)
+cx_Freeze:
+cx_Freeze: cx_Freeze is a set of scripts and modules for freezing Python
+cx_Freeze: scripts into executables in much the same way that py2exe and py2app
+cx_Freeze: do. Unlike these two tools, cx_Freeze is cross platform and should
+cx_Freeze: work on any platform that Python itself works on.
+cx_Freeze:
+cx_Freeze:
+cx_Freeze:
+cx_Freeze:
+cx_Freeze: