summaryrefslogtreecommitdiffstats
path: root/python/cppy
diff options
context:
space:
mode:
author Isaac Yu2022-04-08 06:10:16 +0200
committer Willy Sudiarto Raharjo2022-04-09 10:45:55 +0200
commit1d146cb34b937303c8c26bad35129701b695f512 (patch)
tree4fab4bf2a398f18019a09138542f43fcc199ce7a /python/cppy
parent242648acbf4ba3c8e7c5952e2237e3ab7c525f3c (diff)
downloadslackbuilds-1d146cb34b937303c8c26bad35129701b695f512.tar.gz
python/cppy: Added (C++ header library)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/cppy')
-rw-r--r--python/cppy/README4
-rw-r--r--python/cppy/cppy.SlackBuild82
-rw-r--r--python/cppy/cppy.info10
-rw-r--r--python/cppy/slack-desc19
4 files changed, 115 insertions, 0 deletions
diff --git a/python/cppy/README b/python/cppy/README
new file mode 100644
index 0000000000..f36f1b7715
--- /dev/null
+++ b/python/cppy/README
@@ -0,0 +1,4 @@
+cppy is a small C++ header library which makes it easier to write Python
+extension modules. The primary feature is a PyObject smart pointer which
+automatically handles reference counting and provides convenience
+methods for performing common object operations.
diff --git a/python/cppy/cppy.SlackBuild b/python/cppy/cppy.SlackBuild
new file mode 100644
index 0000000000..342f26f47b
--- /dev/null
+++ b/python/cppy/cppy.SlackBuild
@@ -0,0 +1,82 @@
+#!/bin/bash
+
+# Slackware build script for cppy
+
+# Copyright 2022 Isaac Yu <isaacyu1@isaacyu1.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification,
+# is permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR
+# IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+# DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT,
+# INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+# (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+# SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+# HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
+# STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING
+# IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+# POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=cppy
+VERSION=${VERSION:-1.2.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=${PKG:-$TMP/package-$PRGNAM}
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root $PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE PKG-INFO README.rst releasenotes.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/cppy/cppy.info b/python/cppy/cppy.info
new file mode 100644
index 0000000000..627bf0eea6
--- /dev/null
+++ b/python/cppy/cppy.info
@@ -0,0 +1,10 @@
+PRGNAM="cppy"
+VERSION="1.2.0"
+HOMEPAGE="https://github.com/nucleic/cppy"
+DOWNLOAD="https://github.com/nucleic/cppy/releases/download/1.2.0/cppy-1.2.0.tar.gz"
+MD5SUM="d5790863221465f259f751252a259654"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Isaac Yu"
+EMAIL="isaacyu1@isaacyu1.com"
diff --git a/python/cppy/slack-desc b/python/cppy/slack-desc
new file mode 100644
index 0000000000..fcad29be57
--- /dev/null
+++ b/python/cppy/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+cppy: cppy (C++ header library)
+cppy:
+cppy: cppy is a small C++ header library which makes it easier to write
+cppy: Python extension modules.
+cppy:
+cppy:
+cppy:
+cppy:
+cppy:
+cppy:
+cppy: