summaryrefslogtreecommitdiffstats
path: root/python/cocos2d
diff options
context:
space:
mode:
author klaatu2017-04-01 17:06:07 +0200
committer Willy Sudiarto Raharjo2017-04-08 01:57:41 +0200
commitc379329859ff878636524de03f81d061a6b20f07 (patch)
treeb45a214d551beeb5c1f832e420130c1c4068647c /python/cocos2d
parente2fa83f9692d6d52515caca003323813c7360281 (diff)
downloadslackbuilds-c379329859ff878636524de03f81d061a6b20f07.tar.gz
python/cocos2d: Added (python game engine).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python/cocos2d')
-rw-r--r--python/cocos2d/README11
-rw-r--r--python/cocos2d/cocos2d.SlackBuild62
-rw-r--r--python/cocos2d/cocos2d.info10
-rw-r--r--python/cocos2d/slack-desc19
4 files changed, 102 insertions, 0 deletions
diff --git a/python/cocos2d/README b/python/cocos2d/README
new file mode 100644
index 0000000000..2fcecacd02
--- /dev/null
+++ b/python/cocos2d/README
@@ -0,0 +1,11 @@
+cocos2d is a framework for building 2D games, demos,
+and other graphical/interactive applications.
+
+It works on Windows, OS X and Linux and it is meant
+to be used by applications written in Python 2.x or 3.x
+
+
+Recommended Optional Dependencies
+
+numpy (for particles)
+avbin (for sound and video)
diff --git a/python/cocos2d/cocos2d.SlackBuild b/python/cocos2d/cocos2d.SlackBuild
new file mode 100644
index 0000000000..64bd6648fa
--- /dev/null
+++ b/python/cocos2d/cocos2d.SlackBuild
@@ -0,0 +1,62 @@
+#!/bin/sh
+# Slackware build script for Cocos2d
+
+# Copyright 2017 Klaatu, Wellington NZ.
+# GNU All-Permissive License
+# Copying and distribution of this file, with or without modification,
+# are permitted in any medium without royalty provided the copyright
+# notice and this notice are preserved. This file is offered as-is,
+# without any warranty.
+
+PRGNAM=cocos2d
+SRCNAM=cocos
+VERSION=${VERSION:-0.6.4}
+SRCVER=release-$VERSION
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$SRCVER
+tar xvf $CWD/$SRCNAM-$SRCVER.tar.gz
+cd $SRCNAM-$SRCVER
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS.txt CHANGELOG CONTRIBUTING.rst \
+ INSTALL LICENS* MANIFEST.in NEWS.txt README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/cocos2d/cocos2d.info b/python/cocos2d/cocos2d.info
new file mode 100644
index 0000000000..a0b5ee77c0
--- /dev/null
+++ b/python/cocos2d/cocos2d.info
@@ -0,0 +1,10 @@
+PRGNAM="cocos2d"
+VERSION="0.6.4"
+HOMEPAGE="http://python.cocos2d.org/"
+DOWNLOAD="https://github.com/los-cocos/cocos/archive/release-0.6.4/cocos-release-0.6.4.tar.gz"
+MD5SUM="ae5ead930fb2629e0daeec696681a185"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pyglet"
+MAINTAINER="klaatu"
+EMAIL="klaatu@member.fsf.org"
diff --git a/python/cocos2d/slack-desc b/python/cocos2d/slack-desc
new file mode 100644
index 0000000000..63ae8ae9c6
--- /dev/null
+++ b/python/cocos2d/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+cocos2d: cocos2d (python game engine)
+cocos2d:
+cocos2d: Cocos2d is a framework for building 2D games, demos, and other
+cocos2d: graphical/interactive applications.
+cocos2d:
+cocos2d: http://python.cocos2d.org
+cocos2d:
+cocos2d:
+cocos2d:
+cocos2d:
+cocos2d: