summaryrefslogtreecommitdiffstats
path: root/python/buildbot
diff options
context:
space:
mode:
author Dave Woodfall2021-05-15 17:28:28 +0200
committer Willy Sudiarto Raharjo2021-05-19 13:40:10 +0200
commit8964ec71ece0c6d59f519df90f8b24405086dd74 (patch)
tree538aeb3c98f39b08829d55b9ab78cd02083a44f1 /python/buildbot
parent9a4a14e578a8daba588ce0193c8ed7ba224ab027 (diff)
downloadslackbuilds-8964ec71ece0c6d59f519df90f8b24405086dd74.tar.gz
python/buildbot: Convert python to python2.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/buildbot')
-rw-r--r--python/buildbot/README22
-rw-r--r--python/buildbot/buildbot.SlackBuild2
-rw-r--r--python/buildbot/buildbot.info2
3 files changed, 14 insertions, 12 deletions
diff --git a/python/buildbot/README b/python/buildbot/README
index f8cf037869..6e3d4e8b32 100644
--- a/python/buildbot/README
+++ b/python/buildbot/README
@@ -1,12 +1,14 @@
-The BuildBot is a system to automate the compile/test cycle required by most
-software projects to validate code changes. By automatically rebuilding and
-testing the tree each time something has changed, build problems are pinpointed
-quickly, before other developers are inconvenienced by the failure. The guilty
-developer can be identified and harassed without human intervention. By running
-the builds on a variety of platforms, developers who do not have the facilities
-to test their changes everywhere before checkin will at least know shortly
-afterwards whether they have broken the build or not. Warning counts, lint
-checks, image size, compile time, and other build parameters can be tracked
-over time, are more visible, and are therefore easier to improve.
+The BuildBot is a system to automate the compile/test cycle required by
+most software projects to validate code changes. By automatically
+rebuilding and testing the tree each time something has changed, build
+problems are pinpointed quickly, before other developers are
+inconvenienced by the failure. The guilty developer can be identified
+and harassed without human intervention. By running the builds on a
+variety of platforms, developers who do not have the facilities to test
+their changes everywhere before checkin will at least know shortly
+afterwards whether they have broken the build or not. Warning counts,
+lint checks, image size, compile time, and other build parameters can be
+tracked over time, are more visible, and are therefore easier to
+improve.
See also buildbot-slave (the slave component of BuildBot).
diff --git a/python/buildbot/buildbot.SlackBuild b/python/buildbot/buildbot.SlackBuild
index b94ceaa0e6..5d2a7a0dc6 100644
--- a/python/buildbot/buildbot.SlackBuild
+++ b/python/buildbot/buildbot.SlackBuild
@@ -69,7 +69,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
mkdir -p $PKG/usr/man/man1
gzip -9 < docs/buildbot.1 > $PKG/usr/man/man1/buildbot.1.gz
diff --git a/python/buildbot/buildbot.info b/python/buildbot/buildbot.info
index ff4f3c2821..0899fe6bd2 100644
--- a/python/buildbot/buildbot.info
+++ b/python/buildbot/buildbot.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://pypi.python.org/packages/39/19/c8f8845d302b7df9d44a86a00911ccd
MD5SUM="a915481515675800448d3e6a99a15e14"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python-dateutil Jinja2 sqlalchemy-migrate sqlparse python-twisted"
+REQUIRES="python2-dateutil Jinja2 sqlalchemy-migrate sqlparse python2-twisted"
MAINTAINER="David Spencer"
EMAIL="baildon.research@googlemail.com"