summaryrefslogtreecommitdiffstats
path: root/python/buildbot-badges
diff options
context:
space:
mode:
author Yth - Arnaud2022-04-05 10:04:19 +0200
committer Willy Sudiarto Raharjo2022-04-09 10:45:44 +0200
commitdb460d5cd7e2ce91f17d0490862ddaef780dac07 (patch)
tree82f516619d9dcfc356e6a5252d25b8cc9940ec85 /python/buildbot-badges
parentea9be7d4ab7622256890e1caffb850512c6dec36 (diff)
downloadslackbuilds-db460d5cd7e2ce91f17d0490862ddaef780dac07.tar.gz
python/buildbot-badges: Added (Plugin for buildbot).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/buildbot-badges')
-rw-r--r--python/buildbot-badges/README7
-rw-r--r--python/buildbot-badges/buildbot-badges.SlackBuild97
-rw-r--r--python/buildbot-badges/buildbot-badges.info10
-rw-r--r--python/buildbot-badges/slack-desc19
4 files changed, 133 insertions, 0 deletions
diff --git a/python/buildbot-badges/README b/python/buildbot-badges/README
new file mode 100644
index 0000000000..42a6f7b91f
--- /dev/null
+++ b/python/buildbot-badges/README
@@ -0,0 +1,7 @@
+Buildbot badges is a plugin for buildbot.
+
+Buildbot badges produces an image in SVG or PNG format with information
+about the last build for the given builder name.
+PNG generation is based on the CAIRO SVG engine, it requires a bit more
+CPU to generate.
+
diff --git a/python/buildbot-badges/buildbot-badges.SlackBuild b/python/buildbot-badges/buildbot-badges.SlackBuild
new file mode 100644
index 0000000000..c2d014fd38
--- /dev/null
+++ b/python/buildbot-badges/buildbot-badges.SlackBuild
@@ -0,0 +1,97 @@
+#!/bin/bash
+
+# Slackware build script for python3 buildbot-badges
+
+# Copyright 2022 Yth | Pont-en-Royans, France | yth@ythogtha.org
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=buildbot-badges
+SRCNAM=${PRGNAM#python3-*}
+VERSION=${VERSION:-3.5.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+mkdir $SRCNAM-$VERSION
+cd $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+cd $SRCNAM-$VERSION
+python3 setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ PKG-INFO* \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/buildbot-badges/buildbot-badges.info b/python/buildbot-badges/buildbot-badges.info
new file mode 100644
index 0000000000..fcec78f850
--- /dev/null
+++ b/python/buildbot-badges/buildbot-badges.info
@@ -0,0 +1,10 @@
+PRGNAM="buildbot-badges"
+VERSION="3.5.0"
+HOMEPAGE="https://buildbot.net/"
+DOWNLOAD="https://pypi.python.org/packages/source/b/buildbot-badges/buildbot-badges-3.5.0.tar.gz"
+MD5SUM="2b4390b35cafca075e8b71b06c6fbd66"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="buildbot python3-klein CairoSVG"
+MAINTAINER="Yth - Arnaud"
+EMAIL="yth@ythogtha.org"
diff --git a/python/buildbot-badges/slack-desc b/python/buildbot-badges/slack-desc
new file mode 100644
index 0000000000..795728384f
--- /dev/null
+++ b/python/buildbot-badges/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+buildbot-badges: buildbot-badges (Plugin for buildbot)
+buildbot-badges:
+buildbot-badges: Buildbot badges produces an image in SVG or PNG format with
+buildbot-badges: information about the last build for the given builder name.
+buildbot-badges:
+buildbot-badges: PNG generation is based on the CAIRO SVG engine, it requires
+buildbot-badges: a bit more CPU to generate.
+buildbot-badges:
+buildbot-badges: http://docs.buildbot.net/current/manual/configuration/www.html#badges
+buildbot-badges:
+buildbot-badges: