summaryrefslogtreecommitdiffstats
path: root/python/bsddb3
diff options
context:
space:
mode:
author David Spencer2017-04-07 17:19:19 +0200
committer Willy Sudiarto Raharjo2017-04-08 01:57:49 +0200
commit97d3a51dd86657fbfbd7d1b11ce3771c836c9adc (patch)
tree185cce4109a2673eace0d2d25e226df831f60d79 /python/bsddb3
parent473fdf0791a8015d074aa9d52a1ac55fb7ccbf8f (diff)
downloadslackbuilds-97d3a51dd86657fbfbd7d1b11ce3771c836c9adc.tar.gz
python/bsddb3: Add python3 support.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python/bsddb3')
-rw-r--r--python/bsddb3/README6
-rw-r--r--python/bsddb3/bsddb3.SlackBuild5
2 files changed, 11 insertions, 0 deletions
diff --git a/python/bsddb3/README b/python/bsddb3/README
index 0dd2394514..1d63c26b04 100644
--- a/python/bsddb3/README
+++ b/python/bsddb3/README
@@ -8,3 +8,9 @@ objects can use various access methods: btree, hash, recno, and
queue. Complete support of Berkeley DB distributed transactions.
Complete support for Berkeley DB Replication Manager. Complete
support for Berkeley DB Base Replication. Support for RPC.
+
+
+python3 is an optional dependency. You need to set PYTHON3=yes,
+for example:
+
+ PYTHON3=yes ./bsddb3.SlackBuild
diff --git a/python/bsddb3/bsddb3.SlackBuild b/python/bsddb3/bsddb3.SlackBuild
index 4c97228294..320a815bba 100644
--- a/python/bsddb3/bsddb3.SlackBuild
+++ b/python/bsddb3/bsddb3.SlackBuild
@@ -71,6 +71,11 @@ find -L . \
python setup.py install --root=$PKG
+if [ "${PYTHON3:-no}" = "yes" ]; then
+ rm -rf build
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true