summaryrefslogtreecommitdiffstats
path: root/python/artifacts
diff options
context:
space:
mode:
author B. Watson2022-04-08 17:27:09 +0200
committer Willy Sudiarto Raharjo2022-04-09 10:45:10 +0200
commit841b9792e553402fae8b6de69e6317c8a7d00f3b (patch)
tree41aa62f59670f062d70916306ceef0c0391484ef /python/artifacts
parentc8a7d4e15d08f8c6029dc4fb29db0c0ee9c7934a (diff)
downloadslackbuilds-841b9792e553402fae8b6de69e6317c8a7d00f3b.tar.gz
python/artifacts: Fix docs.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/artifacts')
-rw-r--r--python/artifacts/artifacts.SlackBuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/python/artifacts/artifacts.SlackBuild b/python/artifacts/artifacts.SlackBuild
index 26be139bc5..6a68184aff 100644
--- a/python/artifacts/artifacts.SlackBuild
+++ b/python/artifacts/artifacts.SlackBuild
@@ -23,11 +23,14 @@
#
# Updated to version 20190113, March 2019
+# 20220408 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - get rid of /usr/share/doc.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=artifacts
VERSION=${VERSION:-20190113}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +42,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -76,15 +76,16 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
python2 setup.py install --root=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+rm -rf $PKG/usr/share/doc
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a ACKNOWLEDGEMENTS AUTHORS LICENSE README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild