summaryrefslogtreecommitdiffstats
path: root/python/SOAPpy
diff options
context:
space:
mode:
author Robby Workman2011-03-16 07:13:49 +0100
committer Robby Workman2011-03-20 18:33:01 +0100
commit7a1b4848a3d34a263544fadf08178c91c12fbad0 (patch)
tree8987d0fc908e371dfa87445425f59c7514075b37 /python/SOAPpy
parent987d45e99a299c3b24418b2976e8ec9d5f3bf404 (diff)
downloadslackbuilds-7a1b4848a3d34a263544fadf08178c91c12fbad0.tar.gz
python/*: Moved a lot of Python stuff here
The criteria for whether something "belongs" in Development or Libraries or Python or ... is admittedly arbitrary. As a general rule, if it could be either Libraries or Python, it's Python. Otherwise, pick one and we'll go from there... Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python/SOAPpy')
-rw-r--r--python/SOAPpy/README6
-rw-r--r--python/SOAPpy/SOAPpy.SlackBuild81
-rw-r--r--python/SOAPpy/SOAPpy.info10
-rw-r--r--python/SOAPpy/imports.patch48
-rw-r--r--python/SOAPpy/slack-desc19
5 files changed, 164 insertions, 0 deletions
diff --git a/python/SOAPpy/README b/python/SOAPpy/README
new file mode 100644
index 0000000000..0080e72969
--- /dev/null
+++ b/python/SOAPpy/README
@@ -0,0 +1,6 @@
+The goal of the SOAPpy team is to provide a full-featured SOAP library
+for Python that is very simple to use and that fully supports dynamic
+interaction between clients and servers.
+
+SOAPpy requires fpconst and PyXML packages, both avalaible at
+SlackBuilds.org.
diff --git a/python/SOAPpy/SOAPpy.SlackBuild b/python/SOAPpy/SOAPpy.SlackBuild
new file mode 100644
index 0000000000..08215d32d7
--- /dev/null
+++ b/python/SOAPpy/SOAPpy.SlackBuild
@@ -0,0 +1,81 @@
+#!/bin/sh
+
+# Slackware build script for SOAPpy.
+#
+# Copyright 2009-2010 Marco Bonetti <sid77@slackware.it>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=SOAPpy
+VERSION=0.11.6
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+# Automatically determine the architecture we're building on:
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ # Unless $ARCH is already set, use uname -m for all other archs:
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCS="ChangeLog LICENSE PKG-INFO README RELEASE_INFO docs"
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar -xzvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+# fix txts permissions
+chmod 644 docs/*.txt
+
+# Fix imports from future order
+patch -p1 < $CWD/imports.patch
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/SOAPpy/SOAPpy.info b/python/SOAPpy/SOAPpy.info
new file mode 100644
index 0000000000..2bbb88a179
--- /dev/null
+++ b/python/SOAPpy/SOAPpy.info
@@ -0,0 +1,10 @@
+PRGNAM="SOAPpy"
+VERSION="0.11.6"
+HOMEPAGE="http://pywebsvcs.sourceforge.net/"
+DOWNLOAD="http://downloads.sourceforge.net/pywebsvcs/SOAPpy-0.11.6.tar.gz"
+MD5SUM="51ac835366badedd932c64f26fa8336b"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Marco Bonetti"
+EMAIL="sid77@slackware.it"
+APPROVED="dsomero"
diff --git a/python/SOAPpy/imports.patch b/python/SOAPpy/imports.patch
new file mode 100644
index 0000000000..efb2931e6b
--- /dev/null
+++ b/python/SOAPpy/imports.patch
@@ -0,0 +1,48 @@
+diff -Naur SOAPpy-0.11.6.orig/SOAPpy/Client.py SOAPpy-0.11.6/SOAPpy/Client.py
+--- SOAPpy-0.11.6.orig/SOAPpy/Client.py 2004-04-27 17:45:58.000000000 +0200
++++ SOAPpy-0.11.6/SOAPpy/Client.py 2009-03-13 13:15:11.000000000 +0100
+@@ -40,10 +40,10 @@
+ ################################################################################
+ """
+
+-ident = '$Id: Client.py,v 1.20 2004/04/10 04:22:52 irjudson Exp $'
++from __future__ import nested_scopes
+ from version import __version__
+
+-from __future__ import nested_scopes
++ident = '$Id: Client.py,v 1.20 2004/04/10 04:22:52 irjudson Exp $'
+
+ #import xml.sax
+ import urllib
+diff -Naur SOAPpy-0.11.6.orig/SOAPpy/Server.py SOAPpy-0.11.6/SOAPpy/Server.py
+--- SOAPpy-0.11.6.orig/SOAPpy/Server.py 2004-04-28 23:47:10.000000000 +0200
++++ SOAPpy-0.11.6/SOAPpy/Server.py 2009-03-13 13:15:11.000000000 +0100
+@@ -40,10 +40,10 @@
+ ################################################################################
+ """
+
+-ident = '$Id: Server.py,v 1.20 2004/04/28 21:47:10 warnes Exp $'
++from __future__ import nested_scopes
+ from version import __version__
+
+-from __future__ import nested_scopes
++ident = '$Id: Server.py,v 1.20 2004/04/28 21:47:10 warnes Exp $'
+
+ #import xml.sax
+ import re
+diff -Naur SOAPpy-0.11.6.orig/SOAPpy/Types.py SOAPpy-0.11.6/SOAPpy/Types.py
+--- SOAPpy-0.11.6.orig/SOAPpy/Types.py 2004-09-11 05:03:33.000000000 +0200
++++ SOAPpy-0.11.6/SOAPpy/Types.py 2009-03-13 13:15:11.000000000 +0100
+@@ -33,10 +33,10 @@
+ ################################################################################
+ """
+
+-ident = '$Id: Types.py,v 1.17 2004/09/11 03:03:33 warnes Exp $'
++from __future__ import nested_scopes
+ from version import __version__
+
+-from __future__ import nested_scopes
++ident = '$Id: Types.py,v 1.17 2004/09/11 03:03:33 warnes Exp $'
+
+ import UserList
+ import base64
diff --git a/python/SOAPpy/slack-desc b/python/SOAPpy/slack-desc
new file mode 100644
index 0000000000..db03288ff9
--- /dev/null
+++ b/python/SOAPpy/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+SOAPpy: SOAPpy (SOAP library for Python)
+SOAPpy:
+SOAPpy: The goal of the SOAPpy team is to provide a full-featured SOAP library
+SOAPpy: for Python that is very simple to use and that fully supports dynamic
+SOAPpy: interaction between clients and servers.
+SOAPpy:
+SOAPpy:
+SOAPpy:
+SOAPpy:
+SOAPpy:
+SOAPpy: