summaryrefslogtreecommitdiffstats
path: root/python/Pygments
diff options
context:
space:
mode:
author Andy Alt2012-04-30 02:16:40 +0200
committer Erik Hanson2012-04-30 07:40:05 +0200
commit3083d7626d834d262d01942c270cf48608faa171 (patch)
tree25c949706aac0f2bb69a5bf136ca45af513f4011 /python/Pygments
parentb8554585093ab792db3da31b994db59212a483e0 (diff)
downloadslackbuilds-3083d7626d834d262d01942c270cf48608faa171.tar.gz
python/Pygments: Updated for version 1.5 and moved from development.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'python/Pygments')
-rw-r--r--python/Pygments/Pygments.SlackBuild61
-rw-r--r--python/Pygments/Pygments.info10
-rw-r--r--python/Pygments/README11
-rw-r--r--python/Pygments/slack-desc19
4 files changed, 101 insertions, 0 deletions
diff --git a/python/Pygments/Pygments.SlackBuild b/python/Pygments/Pygments.SlackBuild
new file mode 100644
index 0000000000..dfcc881cfc
--- /dev/null
+++ b/python/Pygments/Pygments.SlackBuild
@@ -0,0 +1,61 @@
+#!/bin/sh
+
+# Slackware build script for Pygments
+
+# Written by Grissiom <chaos.proton@gmail.com>
+# Updated by LukenShiro, Italy
+
+PRGNAM=Pygments
+VERSION=${VERSION:-1.5}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCFILES="LICENSE TODO AUTHORS CHANGES docs/build/*.html"
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --prefix=/usr --root=$PKG
+
+mkdir -p $PKG/usr/man/man1
+cp -a docs/pygmentize.1 $PKG/usr/man/man1
+# Adapting to Slackware's directory layout
+sed -i "s|share/doc/python-pygments|doc/${PRGNAM}-${VERSION}|" \
+ $PKG/usr/man/man1/pygmentize.1
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/Pygments/Pygments.info b/python/Pygments/Pygments.info
new file mode 100644
index 0000000000..c6444e4458
--- /dev/null
+++ b/python/Pygments/Pygments.info
@@ -0,0 +1,10 @@
+PRGNAM="Pygments"
+VERSION="1.5"
+HOMEPAGE="http://pygments.org/"
+DOWNLOAD="http://pypi.python.org/packages/source/P/Pygments/Pygments-1.5.tar.gz"
+MD5SUM="ef997066cc9ee7a47d01fb4f3da0b5ff"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="LukenShiro"
+EMAIL="lukenshiro@ngi.it"
+APPROVED="dsomero"
diff --git a/python/Pygments/README b/python/Pygments/README
new file mode 100644
index 0000000000..975ce911d5
--- /dev/null
+++ b/python/Pygments/README
@@ -0,0 +1,11 @@
+Pygments is a generic syntax highlighter for general use in all kinds of
+software such as forum systems, wikis or other applications that need to
+prettify source code.
+
+Highlights are:
+ * A wide range of common languages and markup formats is supported.
+ * Special attention is paid to details, increasing quality by a fair amount.
+ * Support for new languages and formats are added easily.
+ * A number of output formats, presently HTML, LaTeX, RTF, SVG and ANSI
+ sequences.
+ * It is usable as a command-line tool and as a library.
diff --git a/python/Pygments/slack-desc b/python/Pygments/slack-desc
new file mode 100644
index 0000000000..31af28f8ad
--- /dev/null
+++ b/python/Pygments/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+Pygments: Pygments (syntax highlighting package written in Python)
+Pygments:
+Pygments: It is a generic syntax highlighter for general use in all kinds of
+Pygments: software such as forum systems, wikis or other applications that need
+Pygments: to prettify source code. A wide range of common languages and markup
+Pygments: formats is supported.
+Pygments:
+Pygments:
+Pygments:
+Pygments:
+Pygments: