summaryrefslogtreecommitdiffstats
path: root/python/PyPDF2
diff options
context:
space:
mode:
author Brenton Earl2017-09-04 13:46:28 +0200
committer David Spencer2017-09-05 00:10:57 +0200
commitfae5027600e3222a7dbb3705e9fa48ba2a13d59c (patch)
tree8257d80825271de640bed52d6139cda8d72da4a5 /python/PyPDF2
parent4b8e31c0e3d84531f7082aec60be88918ffd3e87 (diff)
downloadslackbuilds-fae5027600e3222a7dbb3705e9fa48ba2a13d59c.tar.gz
python/PyPDF2: Added (Python PDF toolkit).
This was previously named pyPdf in our repository. The name pyPdf is being reused for the original pyPdf package, from which PyPDF2 was forked. Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python/PyPDF2')
-rw-r--r--python/PyPDF2/PyPDF2.SlackBuild89
-rw-r--r--python/PyPDF2/PyPDF2.info10
-rw-r--r--python/PyPDF2/README14
-rw-r--r--python/PyPDF2/slack-desc19
4 files changed, 132 insertions, 0 deletions
diff --git a/python/PyPDF2/PyPDF2.SlackBuild b/python/PyPDF2/PyPDF2.SlackBuild
new file mode 100644
index 0000000000..810500e285
--- /dev/null
+++ b/python/PyPDF2/PyPDF2.SlackBuild
@@ -0,0 +1,89 @@
+#!/bin/sh
+
+# Slackware build script for PyPDF2.
+
+# Copyright 2009-2011 Marco Bonetti <sid77@slackware.it>
+# Copyright 2015-2017 Brenton Earl <brent@exitstatusone.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=PyPDF2
+VERSION=${VERSION:-1.26.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCS="CHANGELOG LICENSE README.md"
+SAMPLES="Scripts/ Sample_Code/ Resources/"
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -ar $DOCS $SAMPLES $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/PyPDF2/PyPDF2.info b/python/PyPDF2/PyPDF2.info
new file mode 100644
index 0000000000..7350b3e4f9
--- /dev/null
+++ b/python/PyPDF2/PyPDF2.info
@@ -0,0 +1,10 @@
+PRGNAM="PyPDF2"
+VERSION="1.26.0"
+HOMEPAGE="https://mstamy2.github.io/PyPDF2/"
+DOWNLOAD="https://github.com/mstamy2/PyPDF2/archive/1.26.0/PyPDF2-1.26.0.tar.gz"
+MD5SUM="3959e3a15606e4b6c0405487cefb4e21"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Brenton Earl"
+EMAIL="brent@exitstatusone.com"
diff --git a/python/PyPDF2/README b/python/PyPDF2/README
new file mode 100644
index 0000000000..80f9b05996
--- /dev/null
+++ b/python/PyPDF2/README
@@ -0,0 +1,14 @@
+A Pure-Python library built as a PDF toolkit. It is capable of:
+ * extracting document information (title, author, ...)
+ * splitting documents page by page
+ * merging documents page by page
+ * cropping pages
+ * merging multiple pages into a single page
+ * encrypting and decrypting PDF files
+
+By being Pure-Python, it should run on any Python platform without any
+dependencies on external libraries. It can also work entirely on StringIO
+objects rather than file streams, allowing for PDF manipulation in memory. It is
+therefore a useful tool for websites that manage or manipulate PDFs.
+
+NOTE: This is a fork of pyPdf, which is available on SBo separately.
diff --git a/python/PyPDF2/slack-desc b/python/PyPDF2/slack-desc
new file mode 100644
index 0000000000..eaa7bfc90a
--- /dev/null
+++ b/python/PyPDF2/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+PyPDF2: PyPDF2 (Python PDF toolkit)
+PyPDF2:
+PyPDF2: A Pure-Python library built as a PDF toolkit.
+PyPDF2:
+PyPDF2:
+PyPDF2:
+PyPDF2:
+PyPDF2:
+PyPDF2:
+PyPDF2:
+PyPDF2: