summaryrefslogtreecommitdiffstats
path: root/python/Mako
diff options
context:
space:
mode:
author Hunter Sezen2017-10-22 02:27:56 +0200
committer Willy Sudiarto Raharjo2017-10-26 04:24:56 +0200
commitdf1c07da24af3061131484b7b0b7746a55f0d788 (patch)
treeb4031abb6b877b8fd9d3ce389df77fd16cc234aa /python/Mako
parentbfc6e66ba1c099898966c982cb8947eef9014b27 (diff)
downloadslackbuilds-df1c07da24af3061131484b7b0b7746a55f0d788.tar.gz
python/Mako: Updated for version 1.0.7 + new maintainer.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/Mako')
-rw-r--r--python/Mako/Mako.SlackBuild34
-rw-r--r--python/Mako/Mako.info10
-rw-r--r--python/Mako/README15
3 files changed, 37 insertions, 22 deletions
diff --git a/python/Mako/Mako.SlackBuild b/python/Mako/Mako.SlackBuild
index e1fcc6fe19..814d6ef087 100644
--- a/python/Mako/Mako.SlackBuild
+++ b/python/Mako/Mako.SlackBuild
@@ -3,15 +3,33 @@
# Slackware build script for Mako
# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2017 Hunter Sezen California, USA
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=Mako
-VERSION=${VERSION:-1.0.0}
+VERSION=${VERSION:-1.0.7}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -22,7 +40,7 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-set -e
+set -eu
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
@@ -35,16 +53,12 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG --no-compile
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+python setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- CHANGES LICENSE README.rst doc/* \
+cp -a AUTHORS CHANGES LICENSE README.rst doc/*.html \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/python/Mako/Mako.info b/python/Mako/Mako.info
index f5d432b571..b4c0c8c614 100644
--- a/python/Mako/Mako.info
+++ b/python/Mako/Mako.info
@@ -1,10 +1,10 @@
PRGNAM="Mako"
-VERSION="1.0.0"
+VERSION="1.0.7"
HOMEPAGE="http://www.makotemplates.org/"
-DOWNLOAD="https://pypi.python.org/packages/source/M/Mako/Mako-1.0.0.tar.gz"
-MD5SUM="ae27c6512832fe528bb67f1a851921cc"
+DOWNLOAD="https://pypi.python.org/packages/eb/f3/67579bb486517c0d49547f9697e36582cd19dafb5df9e687ed8e22de57fa/Mako-1.0.7.tar.gz"
+MD5SUM="5836cc997b1b773ef389bf6629c30e65"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="MarkupSafe"
-MAINTAINER="Ben Mendis"
-EMAIL="ben.mendis@gmail.com"
+MAINTAINER="Hunter Sezen"
+EMAIL="ovariegata@yahoo.com"
diff --git a/python/Mako/README b/python/Mako/README
index ce0fb67098..9fa6aa27e2 100644
--- a/python/Mako/README
+++ b/python/Mako/README
@@ -1,8 +1,9 @@
Mako is a template library written in Python. It provides a familiar,
-non-XML syntax which compiles into Python modules for maximum performance.
-Mako's syntax and API borrows from the best ideas of many others, including
-Django templates, Cheetah, Myghty, and Genshi. Conceptually, Mako is an
-embedded Python (i.e. Python Server Page) language, which refines the
-familiar ideas of componentized layout and inheritance to produce one of
-the most straightforward and flexible models available, while also
-maintaining close ties to Python calling and scoping semantics.
+non-XML syntax which compiles into Python modules for maximum
+performance. Mako's syntax and API borrows from the best ideas of many
+others, including Django templates, Cheetah, Myghty, and Genshi.
+Conceptually, Mako is an embedded Python (i.e. Python Server Page)
+language, which refines the familiar ideas of componentized layout and
+inheritance to produce one of the most straightforward and flexible
+models available, while also maintaining close ties to Python calling
+and scoping semantics.