summaryrefslogtreecommitdiffstats
path: root/python/DVR-Scan
diff options
context:
space:
mode:
author Fernando Lopez Jr2020-03-28 05:47:57 +0100
committer Willy Sudiarto Raharjo2020-03-28 05:47:57 +0100
commitf21d8884137dbbd205d00c31bef9b16a16a42597 (patch)
treed69a79bd27774609a2a9ea955373755fb4819738 /python/DVR-Scan
parent07205918d4fbf67c8df630ac2c18ae43cb41529e (diff)
downloadslackbuilds-f21d8884137dbbd205d00c31bef9b16a16a42597.tar.gz
python/DVR-Scan: Added (Motion Events Detector).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/DVR-Scan')
-rw-r--r--python/DVR-Scan/DVR-Scan.SlackBuild71
-rw-r--r--python/DVR-Scan/DVR-Scan.info10
-rw-r--r--python/DVR-Scan/README15
-rw-r--r--python/DVR-Scan/slack-desc19
4 files changed, 115 insertions, 0 deletions
diff --git a/python/DVR-Scan/DVR-Scan.SlackBuild b/python/DVR-Scan/DVR-Scan.SlackBuild
new file mode 100644
index 0000000000..5d697c38e0
--- /dev/null
+++ b/python/DVR-Scan/DVR-Scan.SlackBuild
@@ -0,0 +1,71 @@
+#!/bin/sh
+
+# Slackware build script for DVR-Scan
+
+# Copyright 2020 Fernando Lopez Jr. <fernando.lopezjr@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=DVR-Scan
+VERSION=${VERSION:-1.0.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE LICENSE-NUMPY LICENSE-OPENCV MANIFEST.in README.md package-info.rst docs/ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/DVR-Scan/DVR-Scan.info b/python/DVR-Scan/DVR-Scan.info
new file mode 100644
index 0000000000..615d5a9983
--- /dev/null
+++ b/python/DVR-Scan/DVR-Scan.info
@@ -0,0 +1,10 @@
+PRGNAM="DVR-Scan"
+VERSION="1.0.1"
+HOMEPAGE="https://github.com/Breakthrough/DVR-Scan"
+DOWNLOAD="https://github.com/Breakthrough/DVR-Scan/archive/v1.0.1/DVR-Scan-1.0.1.tar.gz"
+MD5SUM="b75bcf44215dd03e1b80b6499c34ffd3"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="opencv numpy3"
+MAINTAINER="Fernando Lopez Jr."
+EMAIL="fernando.lopezjr@gmail.com"
diff --git a/python/DVR-Scan/README b/python/DVR-Scan/README
new file mode 100644
index 0000000000..6bbf670559
--- /dev/null
+++ b/python/DVR-Scan/README
@@ -0,0 +1,15 @@
+DVR-Scan is a cross-platform command-line (CLI) application
+that automatically detects motion events in video files
+(e.g. security camera footage). In addition to locating both
+the time and duration of each motion event, DVR-Scan will save
+the footage of each motion event to a new, separate video clip.
+
+Not only is DVR-Scan free and open-source software (FOSS),
+written in Python, and based on Numpy and OpenCV, it was built
+to be extendable and hackable.
+
+For users wanting finer control over the output video encoding
+method, the default timecode format (HH:MM:SS.nnnn) is compatible
+with most popular video tools, so in most cases the motion events
+DVR-Scan finds can be simply copied and pasted into another tool
+of your choice (e.g. ffmpeg, avconv or the mkvtoolnix suite). \ No newline at end of file
diff --git a/python/DVR-Scan/slack-desc b/python/DVR-Scan/slack-desc
new file mode 100644
index 0000000000..391caf61f5
--- /dev/null
+++ b/python/DVR-Scan/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+DVR-Scan: DVR-Scan (Motion Events Detector)
+DVR-Scan:
+DVR-Scan: a cross-platform command-line (CLI) application that automatically
+DVR-Scan: detects motion events in video files (e.g. security camera footage).
+DVR-Scan: In addition to locating both the time and duration of each motion
+DVR-Scan: event, will save the footage of each motion event to a new, separate
+DVR-Scan: video clip.
+DVR-Scan:
+DVR-Scan: For users wanting finer control over the output video encoding method,
+DVR-Scan: the default timecode format (HH:MM:SS.nnnn) is compatible with most
+DVR-Scan: popular video tools.