summaryrefslogtreecommitdiffstats
path: root/office
diff options
context:
space:
mode:
author Lockywolf2023-11-28 22:07:17 +0100
committer Willy Sudiarto Raharjo2023-11-29 12:18:39 +0100
commit26efaf6aba1c79718b59d3136ed5ed35056176e6 (patch)
tree1d9ebb5b286728ae489ad5006077a823a8274945 /office
parent19dd06d2f4aa7412ecc36daa9cc1aafce5d233aa (diff)
downloadslackbuilds-26efaf6aba1c79718b59d3136ed5ed35056176e6.tar.gz
office/dspdfviewer: Added (pdf viewer).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'office')
-rw-r--r--office/dspdfviewer/README5
-rw-r--r--office/dspdfviewer/doinst.sh3
-rw-r--r--office/dspdfviewer/dspdfviewer.SlackBuild127
-rw-r--r--office/dspdfviewer/dspdfviewer.info10
-rw-r--r--office/dspdfviewer/slack-desc19
5 files changed, 164 insertions, 0 deletions
diff --git a/office/dspdfviewer/README b/office/dspdfviewer/README
new file mode 100644
index 0000000000..13bcb019de
--- /dev/null
+++ b/office/dspdfviewer/README
@@ -0,0 +1,5 @@
+dspdfviewer is a two-sided pdf viewer for latex-beamer presentations.
+
+In Beamer you can generated a presentation with two screens per slide.
+dspdfviewer lets you display one page on your projector, for the
+audience, and one on your laptop, for yourself, with hints.
diff --git a/office/dspdfviewer/doinst.sh b/office/dspdfviewer/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/office/dspdfviewer/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/office/dspdfviewer/dspdfviewer.SlackBuild b/office/dspdfviewer/dspdfviewer.SlackBuild
new file mode 100644
index 0000000000..c2b26778dc
--- /dev/null
+++ b/office/dspdfviewer/dspdfviewer.SlackBuild
@@ -0,0 +1,127 @@
+#!/bin/bash
+
+# Copyright 2023 Lockywolf
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=dspdfviewer
+VERSION=${VERSION:-0.15.1.20230427_d432d8d6}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+
+COMMIT=d432d8d60de3d41a7b9ca1bc031b2344e8009d26
+
+
+ARCH=${ARCH:-}
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) export ARCH=i586 ;;
+ arm*) export ARCH=arm ;;
+ *) export ARCH=$( uname -m ) ;;
+ esac
+fi
+
+PRINT_PACKAGE_NAME=${PRINT_PACKAGE_NAME:-}
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "s390" ]; then
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC -fpermissive -Wno-error -Wno-error=deprecated-declarations"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG
+
+cd $TMP
+rm -rf $PRGNAM-$COMMIT
+tar xvf $CWD/$PRGNAM-$COMMIT.tar.?z* || exit 1
+cd $PRGNAM-$COMMIT || exit 1
+
+
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+sed -i 's|share/man/man1|man/man1|g' CMakeLists.txt
+
+mkdir build
+cd build
+CFLAGS="$SLKCFLAGS" \
+cmake \
+ -DCMAKE_C_FLAGS="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS="$SLKCFLAGS" \
+ -DCMAKE_BUILD_TYPE="Release" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBuildTests=OFF \
+ -DRunDualScreenTests=OFF \
+ -DUseQtFive=yes \
+ .. .
+
+make || exit 1
+make install DESTDIR=$PKG || exit 1
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || :
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || :
+
+ find $PKG/usr/man -type f -exec gzip -9 {} \;
+ for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+)
+
+mkdir -p $PKG/usr/doc/${PRGNAM}-$VERSION
+cp -a \
+ "$CWD/slack-desc" "$CWD/README" "$CWD/$PRGNAM.info" \
+ $PKG/usr/doc/${PRGNAM}-$VERSION
+chown root:root $PKG/usr/doc/${PRGNAM}-$VERSION/*
+
+mkdir -p $PKG/install
+
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+cd $PKG
+
+/sbin/makepkg --xattrs -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
+
diff --git a/office/dspdfviewer/dspdfviewer.info b/office/dspdfviewer/dspdfviewer.info
new file mode 100644
index 0000000000..95d961624b
--- /dev/null
+++ b/office/dspdfviewer/dspdfviewer.info
@@ -0,0 +1,10 @@
+PRGNAM="dspdfviewer"
+VERSION="0.15.1.20230427_d432d8d6"
+HOMEPAGE="http://dspdfviewer.danny-edel.de/"
+DOWNLOAD="https://github.com/dannyedel/dspdfviewer/archive/d432d8d60de3d41a7b9ca1bc031b2344e8009d26/dspdfviewer-d432d8d60de3d41a7b9ca1bc031b2344e8009d26.tar.gz"
+MD5SUM="1c9ac6b554efe33e698e1a1ed3114cf8"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Lockywolf"
+EMAIL="for_sbo.dspdfviewer_2023-05-15@lockywolf.net"
diff --git a/office/dspdfviewer/slack-desc b/office/dspdfviewer/slack-desc
new file mode 100644
index 0000000000..480bdc00c0
--- /dev/null
+++ b/office/dspdfviewer/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+dspdfviewer: dspdfviewer (A two-monitor viewer for two-sided PDF files.)
+dspdfviewer:
+dspdfviewer: dspdfviewer lets you deliver ultrawide latex-beamer presentations
+dspdfviewer: on two monitors.
+dspdfviewer:
+dspdfviewer:
+dspdfviewer:
+dspdfviewer:
+dspdfviewer:
+dspdfviewer:
+dspdfviewer: