summaryrefslogtreecommitdiffstats
path: root/office
diff options
context:
space:
mode:
author B. Watson2022-03-04 19:22:35 +0100
committer Willy Sudiarto Raharjo2022-03-07 02:45:21 +0100
commite51882e3a12c5ad012ca8a33f71c6e5002fd75a9 (patch)
tree02d5e426c88f13eb96c444aa0a1e3c3762a2ea97 /office
parent698e63dcab2829d1f53df7fcb8483a7ca9347ecd (diff)
downloadslackbuilds-e51882e3a12c5ad012ca8a33f71c6e5002fd75a9.tar.gz
office/marave: Removed (PyQt4; unmaintained upstream since 2015)
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'office')
-rw-r--r--office/marave/README3
-rw-r--r--office/marave/doinst.sh3
-rw-r--r--office/marave/marave.SlackBuild104
-rw-r--r--office/marave/marave.desktop9
-rw-r--r--office/marave/marave.info10
-rw-r--r--office/marave/slack-desc19
6 files changed, 0 insertions, 148 deletions
diff --git a/office/marave/README b/office/marave/README
deleted file mode 100644
index 403c7145a4..0000000000
--- a/office/marave/README
+++ /dev/null
@@ -1,3 +0,0 @@
-Marave is a text editor whose goal is to help you focus on writing.
-it's inspired by ommwriter, Darkroom and many other "simple" text
-editors, with a few twists.
diff --git a/office/marave/doinst.sh b/office/marave/doinst.sh
deleted file mode 100644
index 473345de20..0000000000
--- a/office/marave/doinst.sh
+++ /dev/null
@@ -1,3 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
diff --git a/office/marave/marave.SlackBuild b/office/marave/marave.SlackBuild
deleted file mode 100644
index db45addc72..0000000000
--- a/office/marave/marave.SlackBuild
+++ /dev/null
@@ -1,104 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for marave
-
-# Copyright 2014-2017 Dimitris Zlatanidis Orestiada, Greece
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-# 20220218 bkw: Modified by SlackBuilds.org: host the source somewhere
-# besides github, since it's "master.zip": the next time someone commits
-# to the upstream repo, the md5sum will change.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=marave
-VERSION=${VERSION:-0.7}
-SRCVER=${SRCVER:-master}
-BUILD=${BUILD:-2}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$SRCVER
-unzip $CWD/$PRGNAM-$SRCVER.zip || unzip $CWD/$SRCVER.zip
-cd $PRGNAM-$SRCVER
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \+ -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-
-python setup.py install --root=$PKG
-
-mkdir -p $PKG/usr/share/applications
-install -D -m644 $CWD/$PRGNAM.desktop $PKG/usr/share/applications/$PRGNAM.desktop
-
-mkdir -p $PKG/usr/share/pixmaps/
-install -D -m644 marave/icons/marave.svg $PKG/usr/share/pixmaps/marave.svg
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.rst $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/office/marave/marave.desktop b/office/marave/marave.desktop
deleted file mode 100644
index f1d546afb6..0000000000
--- a/office/marave/marave.desktop
+++ /dev/null
@@ -1,9 +0,0 @@
-[Desktop Entry]
-Name=Text Editor (marave)
-Comment=Text Editor
-Exec=marave-editor
-Icon=marave
-Terminal=false
-Type=Application
-Categories=TextEditor;Utility;
-GenericName=Editor
diff --git a/office/marave/marave.info b/office/marave/marave.info
deleted file mode 100644
index b27459cad8..0000000000
--- a/office/marave/marave.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="marave"
-VERSION="0.7"
-HOMEPAGE="https://github.com/ralsina/marave"
-DOWNLOAD="https://slackware.uk/~urchlay/src/marave-master.zip"
-MD5SUM="6ae1fe790429e1c7f277dc8aa8998308"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="pyenchant"
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
diff --git a/office/marave/slack-desc b/office/marave/slack-desc
deleted file mode 100644
index fb9bfce45f..0000000000
--- a/office/marave/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-marave: marave (A text editor that helps you focus on writing)
-marave:
-marave: Marave doesn't just have minimalism and simplicity, it has minimalism
-marave: and simplicity combined with beauty and a palpable design ethic.
-marave: Marave has soul.
-marave:
-marave: Homepage: https://github.com/ralsina/marave
-marave:
-marave:
-marave:
-marave: