summaryrefslogtreecommitdiffstats
path: root/office
diff options
context:
space:
mode:
author B. Watson2020-11-22 08:49:52 +0100
committer Willy Sudiarto Raharjo2020-11-28 19:03:00 +0100
commit1a26745daba1cc03ad1acf9c136b69bb880551ea (patch)
treefa35b989b69df91b23fbd5403a00621d46696542 /office
parentef06c56c1f21401ed6848a2093d87059fbe73567 (diff)
downloadslackbuilds-1a26745daba1cc03ad1acf9c136b69bb880551ea.tar.gz
office/teapot: Add missing diffs.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'office')
-rw-r--r--office/teapot/fix_fltk_build.diff41
-rw-r--r--office/teapot/fix_mbslen_warning.diff11
-rw-r--r--office/teapot/teapot.SlackBuild1
3 files changed, 53 insertions, 0 deletions
diff --git a/office/teapot/fix_fltk_build.diff b/office/teapot/fix_fltk_build.diff
new file mode 100644
index 0000000000..3f4e2e3ed4
--- /dev/null
+++ b/office/teapot/fix_fltk_build.diff
@@ -0,0 +1,41 @@
+diff -Naur teapot-2.3.0/CMakeLists.txt teapot-2.3.0.patched/CMakeLists.txt
+--- teapot-2.3.0/CMakeLists.txt 2020-11-19 00:18:02.217657446 -0500
++++ teapot-2.3.0.patched/CMakeLists.txt 2020-11-19 00:22:05.201635357 -0500
+@@ -40,7 +40,7 @@
+ install(TARGETS teapot DESTINATION bin)
+ endif ()
+
+-find_package(FLTK NO_MODULE)
++find_package(FLTK)
+ if (FLTK_FOUND)
+ include("${FLTK_USE_FILE}")
+
+@@ -52,13 +52,13 @@
+ if (ENABLE_STATIC)
+ target_link_libraries(fteapot teapotlib fltk fltk_images ${LIB_PORTABLEXDR})
+ else ()
+- target_link_libraries(fteapot teapotlib fltk_SHARED fltk_images_SHARED ${LIB_PORTABLEXDR})
++ target_link_libraries(fteapot teapotlib fltk fltk_images ${LIB_PORTABLEXDR})
+ endif ()
+ else ()
+ if (ENABLE_STATIC)
+ target_link_libraries(fteapot teapotlib fltk fltk_images ${LIB_PORTABLEXDR})
+ else ()
+- target_link_libraries(fteapot teapotlib fltk_SHARED ${LIB_PORTABLEXDR})
++ target_link_libraries(fteapot teapotlib fltk fltk_images ${LIB_PORTABLEXDR})
+ endif ()
+ endif ()
+ install(TARGETS fteapot DESTINATION bin)
+diff -Naur teapot-2.3.0/fteapot.fl teapot-2.3.0.patched/fteapot.fl
+--- teapot-2.3.0/fteapot.fl 2020-11-19 00:15:47.506669691 -0500
++++ teapot-2.3.0.patched/fteapot.fl 2020-11-19 00:16:05.569668049 -0500
+@@ -11,6 +11,9 @@
+ decl {\#include <fcntl.h>} {private global
+ }
+
++decl {\#include <unistd.h>} {private global
++}
++
+ decl {\#define shadow _shadow} {private global
+ }
+
diff --git a/office/teapot/fix_mbslen_warning.diff b/office/teapot/fix_mbslen_warning.diff
new file mode 100644
index 0000000000..47b3539b8c
--- /dev/null
+++ b/office/teapot/fix_mbslen_warning.diff
@@ -0,0 +1,11 @@
+diff -Naur teapot-2.3.0/scanner.c teapot-2.3.0.patched/scanner.c
+--- teapot-2.3.0/scanner.c 2012-02-06 06:30:53.000000000 -0500
++++ teapot-2.3.0.patched/scanner.c 2020-11-19 00:24:24.289622714 -0500
+@@ -25,6 +25,7 @@
+ #include "main.h"
+ #include "misc.h"
+ #include "scanner.h"
++#include "utf8.h"
+ /*}}}*/
+
+ /* identcode -- return number of identifier */ /*{{{*/
diff --git a/office/teapot/teapot.SlackBuild b/office/teapot/teapot.SlackBuild
index 9d02a8577c..e08caeb0cc 100644
--- a/office/teapot/teapot.SlackBuild
+++ b/office/teapot/teapot.SlackBuild
@@ -22,6 +22,7 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20201122 bkw: Grr. Forgot to git add the diffs.
# 20201119 bkw: modified by SlackBuilds.org:
# - BUILD=2.
# - Fix fltk builds.