summaryrefslogtreecommitdiffstats
path: root/office
diff options
context:
space:
mode:
author mario2013-06-04 23:15:41 +0200
committer Robby Workman2013-06-05 10:17:44 +0200
commitbab534f26cda6882d85970582a6ffc0cb3700e43 (patch)
treee6a15cacb1a8707b9f4339757fbb8ceab2e61582 /office
parent0c02fa1068b935b037f196957f13f05bac30e110 (diff)
downloadslackbuilds-bab534f26cda6882d85970582a6ffc0cb3700e43.tar.gz
office/text2pdf: Added (Converts text files to PDF)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'office')
-rw-r--r--office/text2pdf/README8
-rw-r--r--office/text2pdf/slack-desc19
-rw-r--r--office/text2pdf/text2pdf.SlackBuild77
-rw-r--r--office/text2pdf/text2pdf.info14
4 files changed, 118 insertions, 0 deletions
diff --git a/office/text2pdf/README b/office/text2pdf/README
new file mode 100644
index 0000000000..77e554fd84
--- /dev/null
+++ b/office/text2pdf/README
@@ -0,0 +1,8 @@
+text2pdf (Converts text files to PDF)
+
+text2pdf makes a 7-bit clean PDF file (version 1.1) from any input
+file. It reads from standard input or a named file, and writes the PDF
+file to standard output. You can specify the font, number of lines
+and columns, paper size and various other options from the command
+line. By default, long lines will be wrapped, and a formfeed character
+(^L) will cause a page break.
diff --git a/office/text2pdf/slack-desc b/office/text2pdf/slack-desc
new file mode 100644
index 0000000000..3565775801
--- /dev/null
+++ b/office/text2pdf/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+text2pdf: text2pdf (Converts text files to PDF)
+text2pdf:
+text2pdf: text2pdf makes a 7-bit clean PDF file (version 1.1) from any input
+text2pdf: file. It reads from standard input or a named file, and writes the
+text2pdf: PDF file to standard output.
+text2pdf: You can specify the font, number of lines and columns, paper size
+text2pdf: and various other options from the command line. By default, long
+text2pdf: lines will be wrapped, and a formfeed character (^L) will cause a
+text2pdf: page break.
+text2pdf:
+text2pdf:
diff --git a/office/text2pdf/text2pdf.SlackBuild b/office/text2pdf/text2pdf.SlackBuild
new file mode 100644
index 0000000000..4c6e0fae0e
--- /dev/null
+++ b/office/text2pdf/text2pdf.SlackBuild
@@ -0,0 +1,77 @@
+#!/bin/sh
+
+# Slackware build script for text2pdf
+
+# Copyright 2013, mario <mario@slackverse.org>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=text2pdf
+VERSION=${VERSION:-1.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+mkdir $PRGNAM-$VERSION
+cp $CWD/{Makefile,text2pdf.c} $PRGNAM-$VERSION
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+make all
+
+install -D -m0755 -oroot -groot text2pdf $PKG/usr/bin/text2pdf
+install -D -m0644 -oroot -groot $CWD/text2pdf.1 $PKG/usr/man/text2pdf.1
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/office/text2pdf/text2pdf.info b/office/text2pdf/text2pdf.info
new file mode 100644
index 0000000000..85fe6bd58f
--- /dev/null
+++ b/office/text2pdf/text2pdf.info
@@ -0,0 +1,14 @@
+PRGNAM="text2pdf"
+VERSION="1.1"
+HOMEPAGE="http://www.eprg.org/pdfcorner/text2pdf/"
+DOWNLOAD="http://www.eprg.org/pdfcorner/text2pdf/text2pdf.c \
+ http://www.eprg.org/pdfcorner/text2pdf/Makefile \
+ http://www.eprg.org/pdfcorner/text2pdf/text2pdf.1"
+MD5SUM="c57f93808682957a30b3179de535ade5 \
+ 30ece65faac108c5c252ae1c317ca00e \
+ 791559dd4270d878aabf3f4b8fbde7f0"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="mario"
+EMAIL="mario@slackverse.org"