summaryrefslogtreecommitdiffstats
path: root/office
diff options
context:
space:
mode:
author Pablo Santamaria2014-02-03 10:58:31 +0100
committer Erik Hanson2014-02-08 18:10:08 +0100
commit924251357c6d0e360e7d8dd4f9f5b63a18cfc3f8 (patch)
tree39684b519f556b4e03eae225033610e62fe127ab /office
parentb0d516353a16846cad36dae2270813d88b4e28f7 (diff)
downloadslackbuilds-924251357c6d0e360e7d8dd4f9f5b63a18cfc3f8.tar.gz
office/hunspell-es: Added (Spanish hunspell dictionaries).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'office')
-rw-r--r--office/hunspell-es/README1
-rw-r--r--office/hunspell-es/hunspell-es.SlackBuild69
-rw-r--r--office/hunspell-es/hunspell-es.info50
-rw-r--r--office/hunspell-es/slack-desc19
4 files changed, 139 insertions, 0 deletions
diff --git a/office/hunspell-es/README b/office/hunspell-es/README
new file mode 100644
index 0000000000..bf2e3d7b9e
--- /dev/null
+++ b/office/hunspell-es/README
@@ -0,0 +1 @@
+Spanish hunspell dictionaries
diff --git a/office/hunspell-es/hunspell-es.SlackBuild b/office/hunspell-es/hunspell-es.SlackBuild
new file mode 100644
index 0000000000..04080d26bb
--- /dev/null
+++ b/office/hunspell-es/hunspell-es.SlackBuild
@@ -0,0 +1,69 @@
+#!/bin/sh
+
+# Slackware build script for hunspell-es
+
+# Copyright 2014, Pablo Santamaria (pablosantamaria@gmail.com)
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# Based on the Arch PKGBUILD
+
+PRGNAM=hunspell-es
+VERSION=${VERSION:-7.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+ARCH="noarch"
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+mkdir -p $PRGNAM-$VERSION
+cd $PRGNAM-$VERSION
+
+for file in $CWD/*.oxt ; do
+ unzip -B $file
+done
+
+install -dm755 $PKG/usr/share/hunspell
+install -m644 es_*.dic es_*.aff $PKG/usr/share/hunspell
+
+install -dm755 $PKG/usr/share/myspell/dicts
+pushd $PKG/usr/share/myspell/dicts
+for file in $PKGDIR/usr/share/hunspell/*; do
+ ln -sv ../../hunspell/$(basename $file) .
+done
+popd
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+install -m644 README.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/office/hunspell-es/hunspell-es.info b/office/hunspell-es/hunspell-es.info
new file mode 100644
index 0000000000..6bab49250e
--- /dev/null
+++ b/office/hunspell-es/hunspell-es.info
@@ -0,0 +1,50 @@
+PRGNAM="hunspell-es"
+VERSION="0.7"
+HOMEPAGE="https://forja.rediris.es/projects/rla-es/"
+DOWNLOAD="http://forja.rediris.es/frs/download.php/2933/es_ANY.oxt \
+ http://forja.rediris.es/frs/download.php/2953/es_AR.oxt \
+ http://forja.rediris.es/frs/download.php/2952/es_BO.oxt \
+ http://forja.rediris.es/frs/download.php/2951/es_CL.oxt \
+ http://forja.rediris.es/frs/download.php/2950/es_CO.oxt \
+ http://forja.rediris.es/frs/download.php/2949/es_CR.oxt \
+ http://forja.rediris.es/frs/download.php/2948/es_CU.oxt \
+ http://forja.rediris.es/frs/download.php/2947/es_DO.oxt \
+ http://forja.rediris.es/frs/download.php/2946/es_EC.oxt \
+ http://forja.rediris.es/frs/download.php/2945/es_ES.oxt \
+ http://forja.rediris.es/frs/download.php/2944/es_GT.oxt \
+ http://forja.rediris.es/frs/download.php/2943/es_HN.oxt \
+ http://forja.rediris.es/frs/download.php/2942/es_MX.oxt \
+ http://forja.rediris.es/frs/download.php/2941/es_NI.oxt \
+ http://forja.rediris.es/frs/download.php/2940/es_PA.oxt \
+ http://forja.rediris.es/frs/download.php/2939/es_PE.oxt \
+ http://forja.rediris.es/frs/download.php/2938/es_PR.oxt \
+ http://forja.rediris.es/frs/download.php/2937/es_PY.oxt \
+ http://forja.rediris.es/frs/download.php/2936/es_SV.oxt \
+ http://forja.rediris.es/frs/download.php/2935/es_UY.oxt \
+ http://forja.rediris.es/frs/download.php/2934/es_VE.oxt"
+MD5SUM="e3d4b38f280e7376178529db2ece982b \
+ 68ee8f4ebc89a1fa461045d4dbb9b7be \
+ 1ebf11b6094e0bfece8e95cc34e7a409 \
+ 092a388101350b77af4fd789668582bd \
+ fc440fd9fc55ca2dfb9bfa34a1e63864 \
+ 7510fd0f4eb3c6e65523a8d0960f77dd \
+ 0ab4b9638f58ddd3d95d1265918ff39e \
+ 24a20fd4d887693afef539e6f1a3b58e \
+ 5d7343a246323ceda58cfbbf1428e279 \
+ 59dd45e6785ed644adbbd73f4f126182 \
+ b1a9be80687e3117c67ac46aad6b8d66 \
+ d0db5bebd6925738b524de9709950f22 \
+ 0de780714f84955112f38f35fb63a894 \
+ d259d7be17c34df76c7de40c80720a39 \
+ 085fbdbed6a2e248630c801881563b7a \
+ f4673063246888995d4eaa2d4a24ee3d \
+ e67bcf891ba9eeaeb57a60ec8e57f1ac \
+ ba98e3197c81db4c572def2c5cca942d \
+ c68ca9d188cb23c88cdd34a069c5a013 \
+ aeb9d39e4d17e9c904c1f3567178aad6 \
+ 8afa9619aede2d9708e799e0f5d0fcab"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Pablo Santamaria"
+EMAIL="pablosantamaria@gmail.com"
diff --git a/office/hunspell-es/slack-desc b/office/hunspell-es/slack-desc
new file mode 100644
index 0000000000..0aaee9c038
--- /dev/null
+++ b/office/hunspell-es/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+hunspell-es: hunspell-es (Spanish hunspell dictionaries)
+hunspell-es:
+hunspell-es: Spanish hunspell dictionaries.
+hunspell-es:
+hunspell-es:
+hunspell-es:
+hunspell-es:
+hunspell-es:
+hunspell-es:
+hunspell-es:
+hunspell-es: