summaryrefslogtreecommitdiffstats
path: root/office
diff options
context:
space:
mode:
author Asaf Ohaion2012-04-20 22:14:52 +0200
committer dsomero2012-04-20 22:14:52 +0200
commit64cf3031faa0047300411d240df82fa85dfb7c12 (patch)
tree4c15436b982f11bc4b09d2c6f705cbef9c533573 /office
parent274abc9d3f169f124a2d8869e1873848d0afef7f (diff)
downloadslackbuilds-64cf3031faa0047300411d240df82fa85dfb7c12.tar.gz
office/color-theme: Added (emacs-lisp mode for skinning your emacs)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'office')
-rw-r--r--office/color-theme/README13
-rw-r--r--office/color-theme/color-theme.SlackBuild80
-rw-r--r--office/color-theme/color-theme.info10
-rw-r--r--office/color-theme/fix_makefile.diff53
-rw-r--r--office/color-theme/slack-desc19
5 files changed, 175 insertions, 0 deletions
diff --git a/office/color-theme/README b/office/color-theme/README
new file mode 100644
index 0000000000..83ade8ad5e
--- /dev/null
+++ b/office/color-theme/README
@@ -0,0 +1,13 @@
+color-theme is an emacs-lisp mode for skinning your emacs.
+
+Features are:
+
+ Huge and extensible theme library
+ Easy to use
+ Works on pretty all emacs flavours
+ Mature source code
+
+Put the following line in your configuration file (~/.emacs for a single user):
+
+(require 'color-theme)
+
diff --git a/office/color-theme/color-theme.SlackBuild b/office/color-theme/color-theme.SlackBuild
new file mode 100644
index 0000000000..eb6d41f710
--- /dev/null
+++ b/office/color-theme/color-theme.SlackBuild
@@ -0,0 +1,80 @@
+#!/bin/sh
+# Slackware build script for color-theme 6.6.0
+# Written by Asaf Ohaion <asaf at hadasa-oss net>
+
+#
+## Copyright 2010 Asaf Ohaion, <asaf at hadasa-oss net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+
+PRGNAM=color-theme
+VERSION=${VERSION:-6.6.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Fix location of info files
+sed "s|share/info|info|g" -i Makefile
+
+patch -p1 < $CWD/fix_makefile.diff
+# make
+make install PREFIX=/usr DESTDIR=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ COPYING AUTHORS BUGS HACKING README ChangeLog \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+# remove unused /etc/emacs
+rm -rf $PKG/etc/emacs
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/office/color-theme/color-theme.info b/office/color-theme/color-theme.info
new file mode 100644
index 0000000000..f7a1805074
--- /dev/null
+++ b/office/color-theme/color-theme.info
@@ -0,0 +1,10 @@
+PRGNAM="color-theme"
+VERSION="6.6.0"
+HOMEPAGE="http://www.nongnu.org/color-theme"
+DOWNLOAD="http://download.savannah.gnu.org/releases/color-theme/color-theme-6.6.0.tar.gz"
+MD5SUM="a4de73c236a6af11ab378bfe18dabcca"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Asaf Ohaion"
+EMAIL="asaf@hadasa-oss.net"
+APPROVED="dsomero"
diff --git a/office/color-theme/fix_makefile.diff b/office/color-theme/fix_makefile.diff
new file mode 100644
index 0000000000..1ff4756437
--- /dev/null
+++ b/office/color-theme/fix_makefile.diff
@@ -0,0 +1,53 @@
+diff -uNr color-theme-6.6.0/Makefile color-theme-6.6.0_/Makefile
+--- color-theme-6.6.0/Makefile 2006-05-28 16:23:31.000000000 +0300
++++ color-theme-6.6.0_/Makefile 2012-03-20 17:44:11.072562905 +0200
+@@ -50,6 +50,11 @@
+ --eval '(setq load-path (cons "." load-path))' \
+ -f batch-byte-compile $<
+
++themes/%.elc: themes/%.el
++ @$(EMACS) $(OPTIONCOMPILE) \
++ --eval '(setq load-path (cons ".." load-path))' \
++ -f batch-byte-compile $<
++
+ %.info: %.texi
+ @echo "No doc yet !"
+ # makeinfo $<
+@@ -69,17 +74,17 @@
+ -rm -f $(MANUAL).info $(MANUAL).html $(TARGET) $(SPECIAL)
+
+ install-info: $(MANUAL).info
+- [ -d $(INFODIR) ] || install -d $(INFODIR)
+- install -m 0644 $(MANUAL).info $(INFODIR)/$(MANUAL)
+- $(INSTALLINFO) $(INFODIR)/$(MANUAL)
++ [ -d $(DESTDIR)/$(INFODIR) ] || install -d $(DESTDIR)/$(INFODIR)
++ install -m 0644 $(MANUAL).info $(DESTDIR)/$(INFODIR)/$(MANUAL)
++ $(INSTALLINFO) $(DESTDIR)/$(INFODIR)/$(MANUAL)
+
+ install-bin: lisp
+- install -d $(ELISPDIR)
+- install -d $(ELISPDIR)/themes
+- install -m 0644 $(ALLSOURCE) $(TARGET) $(ELISPDIR)
+- install -m 0644 $(THEMES_FILES) $(TARGET) $(ELISPDIR)/themes
++ install -d $(DESTDIR)/$(ELISPDIR)
++ install -d $(DESTDIR)/$(ELISPDIR)/themes
++ install -m 0644 $(ALLSOURCE) $(TARGET) $(DESTDIR)/$(ELISPDIR)
++ install -m 0644 $(THEMES_FILES) $(TARGET) $(DESTDIR)/$(ELISPDIR)/themes
+
+-install: install-bin install-info
++install: install-bin
+
+ ## DO NOT TOUCH THIS !
+ ## HELPERS FOR MAINTAINER(S)
+diff -uNr color-theme-6.6.0/Makefile.defs color-theme-6.6.0_/Makefile.defs
+--- color-theme-6.6.0/Makefile.defs 2012-03-20 17:49:36.144588064 +0200
++++ color-theme-6.6.0_/Makefile.defs 2012-03-20 17:48:56.222585031 +0200
+@@ -10,7 +10,7 @@
+ # Installation options
+ # PREFIX is only used here.
+ PREFIX = /usr/local
+-ELISPDIR = $(PREFIX)/share/emacs/site-lisp/color-theme-el
++ELISPDIR = $(PREFIX)/share/emacs/site-lisp/
+ INFODIR = $(PREFIX)/info
+
+ # Command to use to install the Info dir entry
diff --git a/office/color-theme/slack-desc b/office/color-theme/slack-desc
new file mode 100644
index 0000000000..e142b97c27
--- /dev/null
+++ b/office/color-theme/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first "|" above the ":" following the base package name, and the "|"
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. Its also
+# customary to leave one space after the ":".
+
+ |-----handy-ruler------------------------------------------------------|
+color-theme: color-theme (an emacs-lisp mode for skinning your emacs)
+color-theme:
+color-theme: Features are:
+color-theme:
+color-theme: * Huge and extensible theme library
+color-theme: * Easy to use
+color-theme: * Works on pretty all emacs flavours
+color-theme: * Mature source code
+color-theme:
+color-theme:
+color-theme: