summaryrefslogtreecommitdiffstats
path: root/office
diff options
context:
space:
mode:
author Gilcio Amaral2012-01-30 07:26:51 +0100
committer Robby Workman2012-01-30 07:26:51 +0100
commitb6449ca5661f64feb90bcd89447bcb6f95f30515 (patch)
treed8fc12d69cc7af9c538e45ab57221a2d83451c03 /office
parent588a67b546aaf03bc6cabdbe45fc0e1deeeb2169 (diff)
downloadslackbuilds-b6449ca5661f64feb90bcd89447bcb6f95f30515.tar.gz
office/tellico: Updated for version 2.3.5.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'office')
-rw-r--r--office/tellico/README16
-rw-r--r--office/tellico/slack-desc2
-rw-r--r--office/tellico/tellico-2.3.5.patch110
-rw-r--r--office/tellico/tellico.SlackBuild4
-rw-r--r--office/tellico/tellico.info8
5 files changed, 126 insertions, 14 deletions
diff --git a/office/tellico/README b/office/tellico/README
index 892a2a4f67..830eefe011 100644
--- a/office/tellico/README
+++ b/office/tellico/README
@@ -1,16 +1,16 @@
-Tellico is a KDE application for keeping track of your collections. It
+Tellico is a KDE application for keeping track of your collections. It
provides default templates for books, bibliographies, videos, music, coins,
stamps, trading cards, comic books, and wines. Ultimately, the goal is for
-it to be similar in capability to AVCataloger or Readerware, although it's
+it to be similar in capability to AVCataloger or Readerware, although it's
still got a ways to go.
Tellico allows you to enter your collection in a catalogue database, saving
-many different properties like title, author, etc. Two different views of
-your collection are shown. On the left, your entries are grouped together
-by any field you like, allowing you to see how many are in each group. On
+many different properties like title, author, etc. Two different views of
+your collection are shown. On the left, your entries are grouped together
+by any field you like, allowing you to see how many are in each group. On
the right, selected fields are shown in column format, allowing you to sort
-by any field. On the bottom is a customizable HTML view of the current
-entry. The entry editor is a dialog box where you enter the data. You can
+by any field. On the bottom is a customizable HTML view of the current
+entry. The entry editor is a dialog box where you enter the data. You can
even read barcodes with a webcam.
-yaz, exempi and qjson are optional (but recommended) dependencies.
+yaz, exempi, and qjson are optional (but recommended) dependencies.
diff --git a/office/tellico/slack-desc b/office/tellico/slack-desc
index 68af76ade5..8ccfe8e216 100644
--- a/office/tellico/slack-desc
+++ b/office/tellico/slack-desc
@@ -5,7 +5,7 @@
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
- |-----handy-ruler------------------------------------------------------|
+ |-----handy-ruler-----------------------------------------------------|
tellico: Tellico (KDE application for keeping track of your collections)
tellico:
tellico: Tellico is a KDE application for keeping track of your collections.
diff --git a/office/tellico/tellico-2.3.5.patch b/office/tellico/tellico-2.3.5.patch
new file mode 100644
index 0000000000..96e8c64ecb
--- /dev/null
+++ b/office/tellico/tellico-2.3.5.patch
@@ -0,0 +1,110 @@
+From: Robby Stephenson <robby@periapsis.org>
+Date: Fri, 20 Jan 2012 07:45:00 +0000
+Subject: For KDE < 4.6, just use the KLineEdit for filtering dates
+X-Git-Url: http://quickgit.kde.org/?p=tellico.git&amp;a=commitdiff&amp;h=051f0860594091a95a9c94e19c9847b09fcef395
+---
+For KDE < 4.6, just use the KLineEdit for filtering dates
+---
+
+
+--- a/src/filterdialog.cpp
++++ b/src/filterdialog.cpp
+@@ -42,11 +42,11 @@
+ #include <kiconloader.h>
+
+ // KDateComboBox was new in KDE 4.7
+-// use a local copy if building in an earlier version
++// use a local copy if building in KDE 4.6
+ #include <kdeversion.h>
+ #if KDE_IS_VERSION(4,7,0)
+ #include <kdatecombobox.h>
+-#else
++#elif KDE_IS_VERSION(4,6,0)
+ #include "../gui/kdatecombobox.h"
+ #endif
+
+@@ -66,7 +66,7 @@ using Tellico::FilterRuleWidgetLister;
+ using Tellico::FilterDialog;
+
+ FilterRuleWidget::FilterRuleWidget(Tellico::FilterRule* rule_, QWidget* parent_)
+- : KHBox(parent_), m_editRegExp(0), m_editRegExpDialog(0), m_isDate(false) {
++ : KHBox(parent_), m_ruleDate(0), m_editRegExp(0), m_editRegExpDialog(0), m_isDate(false) {
+ initLists();
+ initWidget();
+
+@@ -102,12 +102,13 @@ void FilterRuleWidget::initWidget() {
+ m_valueStack = new QStackedWidget(this);
+ m_ruleValue = new KLineEdit(m_valueStack);
+ connect(m_ruleValue, SIGNAL(textChanged(const QString&)), SIGNAL(signalModified()));
++ m_valueStack->addWidget(m_ruleValue);
+
++#if KDE_IS_VERSION(4,6,0)
+ m_ruleDate = new KDateComboBox(m_valueStack);
+ connect(m_ruleDate, SIGNAL(dateChanged(const QDate&)), SIGNAL(signalModified()));
+-
+- m_valueStack->addWidget(m_ruleValue);
+ m_valueStack->addWidget(m_ruleDate);
++#endif
+
+ if(!KServiceTypeTrader::self()->query(QLatin1String("KRegExpEditor/KRegExpEditor")).isEmpty()) {
+ m_editRegExp = new KPushButton(i18n("Edit..."), this);
+@@ -172,9 +173,15 @@ void FilterRuleWidget::slotRuleFunctionC
+
+ // don't show the date picker if we're using regular expressions
+ if(m_isDate && data != FilterRule::FuncRegExp && data != FilterRule::FuncNotRegExp) {
++#if KDE_IS_VERSION(4,6,0)
+ m_valueStack->setCurrentWidget(m_ruleDate);
+- } else {
++#else
++ // I don't want a translated message but just an unambiguous hint for older versions
++ m_ruleValue->setClickMessage(QLatin1String("2010-12-30"));
++#endif
++} else {
+ m_valueStack->setCurrentWidget(m_ruleValue);
++ m_ruleValue->setClickMessage(QString());
+ }
+ }
+
+@@ -195,7 +202,11 @@ void FilterRuleWidget::setRule(const Tel
+ m_isDate = true;
+ const QDate date = QDate::fromString(rule_->pattern(), Qt::ISODate);
+ if(date.isValid()) {
++#if KDE_IS_VERSION(4,6,0)
+ m_ruleDate->setDate(date);
++#else
++ m_ruleValue->setText(rule_->pattern());
++#endif
+ }
+ }
+ const int idx = m_ruleField->findText(field ? field->title() : QString());
+@@ -218,9 +229,13 @@ Tellico::FilterRule* FilterRuleWidget::r
+ }
+
+ QString ruleValue;
++#if KDE_IS_VERSION(4,6,0)
+ if(m_valueStack->currentWidget() == m_ruleDate) {
+ ruleValue = m_ruleDate->date().toString(Qt::ISODate);
+ } else {
++#else
++ if(true) {
++#endif
+ ruleValue = m_ruleValue->text().trimmed();
+ }
+
+
+--- a/src/gui/CMakeLists.txt
++++ b/src/gui/CMakeLists.txt
+@@ -34,9 +34,9 @@ SET(gui_STAT_SRCS
+ )
+
+ # The KDateComboBox class was added to KDE in version 4.7
+-# If we're building under an earlier version, use a local copy
+-IF(${KDE_VERSION} VERSION_LESS "4.6.99")
++# If we're building under KDE 4.6, use a local copy
++IF(${KDE_VERSION} VERSION_LESS "4.6.99" AND ${KDE_VERSION} VERSION_GREATER "4.5.99")
+ LIST(APPEND gui_STAT_SRCS kdatecombobox.cpp)
+-ENDIF(${KDE_VERSION} VERSION_LESS "4.6.99")
++ENDIF(${KDE_VERSION} VERSION_LESS "4.6.99" AND ${KDE_VERSION} VERSION_GREATER "4.5.99")
+
+ KDE4_ADD_LIBRARY(gui STATIC ${gui_STAT_SRCS})
+
diff --git a/office/tellico/tellico.SlackBuild b/office/tellico/tellico.SlackBuild
index f561d79220..58297c7c7d 100644
--- a/office/tellico/tellico.SlackBuild
+++ b/office/tellico/tellico.SlackBuild
@@ -27,7 +27,7 @@
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=tellico
-VERSION=${VERSION:-2.3.4}
+VERSION=${VERSION:-2.3.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -73,6 +73,8 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+patch -p1 < $CWD/tellico-2.3.5.patch
+
mkdir -p build
cd build
cmake \
diff --git a/office/tellico/tellico.info b/office/tellico/tellico.info
index 94c7db73d5..6b88c6b683 100644
--- a/office/tellico/tellico.info
+++ b/office/tellico/tellico.info
@@ -1,10 +1,10 @@
PRGNAM="tellico"
-VERSION="2.3.4"
+VERSION="2.3.5"
HOMEPAGE="http://tellico-project.org/"
-DOWNLOAD="http://tellico-project.org/files/tellico-2.3.4.tar.bz2"
-MD5SUM="0a955754e89fc96d9745266ec97410c7"
+DOWNLOAD="http://tellico-project.org/files/tellico-2.3.5.tar.bz2"
+MD5SUM="e6a1835d2622b79c4bfd95271bce858e"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Gilcio Amaral"
EMAIL="gilcio.amaral@gmail.com"
-APPROVED="rworkman,Niels Horn"
+APPROVED="rworkman"