summaryrefslogtreecommitdiffstats
path: root/office
diff options
context:
space:
mode:
author Jostein Berntsen2011-07-13 10:37:28 +0200
committer Niels Horn2011-07-15 02:54:06 +0200
commit9a9cafb6d50b1c45b689122c9c3345e49e424b6b (patch)
treef6ad55c9b30c46c1e924e5d0ecbb824e3d5c710d /office
parent062c5a4689aba6d92f075ea15ddf6b0e762c290a (diff)
downloadslackbuilds-9a9cafb6d50b1c45b689122c9c3345e49e424b6b.tar.gz
office/tnote: Added (fast note taking tool)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'office')
-rw-r--r--office/tnote/README4
-rw-r--r--office/tnote/slack-desc19
-rw-r--r--office/tnote/tnote.SlackBuild75
-rw-r--r--office/tnote/tnote.info10
4 files changed, 108 insertions, 0 deletions
diff --git a/office/tnote/README b/office/tnote/README
new file mode 100644
index 0000000000..c10d11d5c6
--- /dev/null
+++ b/office/tnote/README
@@ -0,0 +1,4 @@
+Tnote is a small note taking program for the terminal. Tnote aims to be
+a small, quick and easy to use note taking app for the terminal similar
+to sticky style gui note taking apps such as Tomboy notes.
+
diff --git a/office/tnote/slack-desc b/office/tnote/slack-desc
new file mode 100644
index 0000000000..dd003326ac
--- /dev/null
+++ b/office/tnote/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+tnote: tnote (fast note taking tool)
+tnote:
+tnote: tnote is a small note taking program for the terminal. tnote aims to
+tnote: be a small, quick and easy to use note taking app similar to sticky
+tnote: gui note taking apps such as Tomboy notes.
+tnote:
+tnote:
+tnote: http://tnote.sourceforge.net
+tnote:
+tnote:
+tnote:
diff --git a/office/tnote/tnote.SlackBuild b/office/tnote/tnote.SlackBuild
new file mode 100644
index 0000000000..dce2cfda79
--- /dev/null
+++ b/office/tnote/tnote.SlackBuild
@@ -0,0 +1,75 @@
+#!/bin/sh
+
+# Slackware build script for tnote
+
+# Written by Jostein Berntsen <jbernts@broadpark.no>
+
+
+PRGNAM=tnote
+VERSION=${VERSION:-0.2.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Build
+python setup.py install --root=$PKG
+
+mv $PKG/usr/share/man $PKG/usr/man
+rm -rf $PKG/usr/share
+
+find $PKG -depth -type d -empty -delete || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS COPYING Changelog INSTALL PKG-INFO README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+
diff --git a/office/tnote/tnote.info b/office/tnote/tnote.info
new file mode 100644
index 0000000000..fb9dc0da2a
--- /dev/null
+++ b/office/tnote/tnote.info
@@ -0,0 +1,10 @@
+PRGNAM="tnote"
+VERSION="0.2.1"
+HOMEPAGE="http://tnote.sourceforge.net/"
+DOWNLOAD="http://sourceforge.net/projects/tnote/files/tnote/tnote-0.2.1/tnote-0.2.1.tar.gz"
+MD5SUM="17b43996a7889c6f84cd2072c485c1a4"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Jostein Berntsen"
+EMAIL="jbernts@broadpark.no"
+APPROVED="dsomero"