summaryrefslogtreecommitdiffstats
path: root/office
diff options
context:
space:
mode:
author David Woodfall2010-10-17 17:05:41 +0200
committer Robby Workman2010-10-18 03:16:53 +0200
commitbd4ccfaee97531a627c19ff2268cc99769ec7d0a (patch)
tree0d4ffeb7322f79f709f9571ff0ef4c7aa7a886ae /office
parent76b83a1df0816ea5741fabac464b8efc0c3b1bf6 (diff)
downloadslackbuilds-bd4ccfaee97531a627c19ff2268cc99769ec7d0a.tar.gz
office/rednotebook: Updated for version 1.1.1.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'office')
-rw-r--r--office/rednotebook/README6
-rw-r--r--office/rednotebook/doinst.sh10
-rw-r--r--office/rednotebook/rednotebook.SlackBuild54
-rw-r--r--office/rednotebook/rednotebook.info12
-rw-r--r--office/rednotebook/slack-desc7
5 files changed, 63 insertions, 26 deletions
diff --git a/office/rednotebook/README b/office/rednotebook/README
index 64762f74af..102c842f4f 100644
--- a/office/rednotebook/README
+++ b/office/rednotebook/README
@@ -5,5 +5,9 @@ keep track of the stuff you do and the thoughts you have. This
journal software helps you to write whole passages or just facts
and does so in style.
-Requires: pyyaml.
+Dependencies:
+PyYAML
+
+Optional Dependencies:
+pywebkitgtk
diff --git a/office/rednotebook/doinst.sh b/office/rednotebook/doinst.sh
new file mode 100644
index 0000000000..1f8ff67ded
--- /dev/null
+++ b/office/rednotebook/doinst.sh
@@ -0,0 +1,10 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
+
diff --git a/office/rednotebook/rednotebook.SlackBuild b/office/rednotebook/rednotebook.SlackBuild
index 0f2c6132d7..581ad57b67 100644
--- a/office/rednotebook/rednotebook.SlackBuild
+++ b/office/rednotebook/rednotebook.SlackBuild
@@ -1,21 +1,35 @@
#!/bin/sh
-# Slackware build script for rednotebook
-
-# Written by Pablo Santamaria (pablosantamaria@gmail.com)
-
+# Slackware build script for python-rednotebook
+# Copyright 2010 David Woodfall <dave@dawoodfall.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=rednotebook
-VERSION=${VERSION:-0.8.9}
+VERSION=${VERSION:-1.1.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -25,6 +39,20 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
set -e
rm -rf $PKG
@@ -40,19 +68,15 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-python setup.py build
-python setup.py install --prefix=$PKG/usr
-
-mkdir -p $PKG/usr/share/applications
-install -m 644 rednotebook.desktop $PKG/usr/share/applications
-mkdir -p $PKG/usr/share/pixmaps
-install -m 644 rednotebook.png $PKG/usr/share/pixmaps
+python setup.py install --root=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS CHANGELOG LICENSE README* $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS CHANGELOG LICENSE README.Packagers README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/office/rednotebook/rednotebook.info b/office/rednotebook/rednotebook.info
index ca145749e2..79adc1fa2f 100644
--- a/office/rednotebook/rednotebook.info
+++ b/office/rednotebook/rednotebook.info
@@ -1,10 +1,10 @@
PRGNAM="rednotebook"
-VERSION="0.8.9"
-HOMEPAGE="http://digitaldump.wordpress.com/projects/rednotebook/"
-DOWNLOAD="http://downloads.sourceforge.net/project/rednotebook/rednotebook-0.8.9.tar.gz"
-MD5SUM="61a709b1806eef5948926c114a8b5ab7"
+VERSION="1.1.1"
+HOMEPAGE="http://rednotebook.sourceforge.net"
+DOWNLOAD="http://downloads.sourceforge.net/project/rednotebook/rednotebook-1.1.1.tar.gz"
+MD5SUM="89397b4293d767db6df36730741817e4"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-MAINTAINER="Pablo Santamaria"
-EMAIL="pablosantamaria@gmail.com"
+MAINTAINER="David Woodfall"
+EMAIL="dave@dawoodfall.net"
APPROVED="dsomero"
diff --git a/office/rednotebook/slack-desc b/office/rednotebook/slack-desc
index 7cb66b8f02..98b50eeb4e 100644
--- a/office/rednotebook/slack-desc
+++ b/office/rednotebook/slack-desc
@@ -5,16 +5,15 @@
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
- |-----handy-ruler----------------------------------------------------|
-rednotebook: rednotebook (graphical daily journal with calendar)
+ |-----handy-ruler------------------------------------------------------|
+rednotebook: rednotebook (graphical daily journal with calendar)
rednotebook:
rednotebook: RedNotebook is a Desktop Diary that makes it very easy for you to
rednotebook: keep track of the stuff you do and the thoughts you have. This
rednotebook: journal software helps you to write whole passages or just facts
rednotebook: and does so in style.
rednotebook:
+rednotebook: Homepage: http://rednotebook.sourceforge.net
rednotebook:
rednotebook:
rednotebook:
-rednotebook:
-