summaryrefslogtreecommitdiffstats
path: root/office/mythes-id
diff options
context:
space:
mode:
author Ali Ahmadi2017-04-28 15:56:21 +0200
committer Willy Sudiarto Raharjo2017-04-28 15:56:21 +0200
commit22c4a0364525c086469559b2a910634141222b0f (patch)
tree8635297b84869313697f00964bac616024b9cd4d /office/mythes-id
parent97f00f35b086bf1e1a03b9fc8e72444f77adf822 (diff)
downloadslackbuilds-22c4a0364525c086469559b2a910634141222b0f.tar.gz
office/mythes-id: Added (Indonesian Thesaurus).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'office/mythes-id')
-rw-r--r--office/mythes-id/README1
-rw-r--r--office/mythes-id/mythes-id.SlackBuild68
-rw-r--r--office/mythes-id/mythes-id.info10
-rw-r--r--office/mythes-id/slack-desc19
4 files changed, 98 insertions, 0 deletions
diff --git a/office/mythes-id/README b/office/mythes-id/README
new file mode 100644
index 0000000000..7b4f9c2978
--- /dev/null
+++ b/office/mythes-id/README
@@ -0,0 +1 @@
+Indonesian Thesaurus for LibreOffice/Apache OpenOfice.
diff --git a/office/mythes-id/mythes-id.SlackBuild b/office/mythes-id/mythes-id.SlackBuild
new file mode 100644
index 0000000000..37fdebdb95
--- /dev/null
+++ b/office/mythes-id/mythes-id.SlackBuild
@@ -0,0 +1,68 @@
+#!/bin/sh
+
+# Slackware build script for mythes-id
+
+# Copyright 2017 Ali Ahmadi <idnux09@gmail.com>
+# # All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# Based on the Arch PKGBUILD
+
+PRGNAM=mythes-id
+VERSION=${VERSION:-1.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+ARCH="noarch"
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+mkdir -p $PRGNAM-$VERSION
+cd $PRGNAM-$VERSION
+tar xvf $CWD/thes_id_ID.tar.gz
+
+# Putting everything in proper place
+install -dm755 $PKG/usr/share/mythes
+install -m644 th_id_ID_v2.* $PKG/usr/share/mythes
+
+# myspell symlinks
+install -dm755 $PKG/usr/share/myspell/dicts
+pushd $PKG/usr/share/myspell/dicts
+ for file in $PKG/usr/share/mythes/*; do
+ ln -sv ../../mythes/$(basename $file) .
+ done
+popd
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+install -m644 README* $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/office/mythes-id/mythes-id.info b/office/mythes-id/mythes-id.info
new file mode 100644
index 0000000000..b10d487580
--- /dev/null
+++ b/office/mythes-id/mythes-id.info
@@ -0,0 +1,10 @@
+PRGNAM="mythes-id"
+VERSION="1.0"
+HOMEPAGE="https://idnux.wordpress.com/proyek/mythes-id/"
+DOWNLOAD="https://www.dropbox.com/s/yszvp5cfo9t15kz/thes_id_ID.tar.gz"
+MD5SUM="2501f3b189b54407356f34f0d466f648"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Ali Ahmadi"
+EMAIL="idnux09@gmail.com"
diff --git a/office/mythes-id/slack-desc b/office/mythes-id/slack-desc
new file mode 100644
index 0000000000..1efd3bb438
--- /dev/null
+++ b/office/mythes-id/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+mythes-id: mythes-id (Indonesian Thesaurus for LibreOffice/Apache OpenOffice)
+mythes-id:
+mythes-id: Indonesian Thesaurus for LibreOffice/Apache OpenOffice
+mythes-id:
+mythes-id:
+mythes-id:
+mythes-id:
+mythes-id:
+mythes-id:
+mythes-id:
+mythes-id: