summaryrefslogtreecommitdiffstats
path: root/office/fbreader/fbreader.SlackBuild
diff options
context:
space:
mode:
author Audrius Kažukauskas2010-05-11 22:26:05 +0200
committer David Somero2010-05-11 22:26:05 +0200
commita4696f4a108ce8e3d5f02eb9a04d3ba352276c0d (patch)
tree50a27d7d405b0d67624ce60e255bd333682c4507 /office/fbreader/fbreader.SlackBuild
parent814d286b66ca2ba3b42cee4a9e045a673ed34c53 (diff)
downloadslackbuilds-a4696f4a108ce8e3d5f02eb9a04d3ba352276c0d.tar.gz
office/fbreader: Updated for version 0.8.17
Diffstat (limited to 'office/fbreader/fbreader.SlackBuild')
-rw-r--r--office/fbreader/fbreader.SlackBuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/office/fbreader/fbreader.SlackBuild b/office/fbreader/fbreader.SlackBuild
index 1d732a0be9..515d2c4c7c 100644
--- a/office/fbreader/fbreader.SlackBuild
+++ b/office/fbreader/fbreader.SlackBuild
@@ -4,7 +4,7 @@
# Written by Audrius Kažukauskas <neobug@tornado.ktu.lt>
PRGNAM=fbreader
-VERSION=0.8.8d
+VERSION=0.8.17
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -17,6 +17,7 @@ OUTPUT=${OUTPUT:-/tmp}
# If you want to build the gtk interface instead, then change this
# value to 'gtk' or run the script like this:
# UI=gtk ./fbreader.SlackBuild
+# (or UI=qt4 for those who have Qt4 from -current)
UI=${UI:-qt}
if [ "$ARCH" = "i486" ]; then
@@ -52,6 +53,11 @@ sed -i 's|moc-qt3|moc|' makefiles/arch/desktop.mk
sed -i 's|-I /usr/include/qt3|$(shell pkg-config --cflags qt-mt)|' makefiles/arch/desktop.mk
sed -i 's|-lqt-mt|$(shell pkg-config --libs qt-mt)|' makefiles/arch/desktop.mk
+# Fix all Qt4 related flags
+sed -i 's|moc-qt4|moc|' makefiles/arch/desktop.mk
+sed -i 's|-I /usr/include/qt4|$(shell pkg-config --cflags QtGui)|' makefiles/arch/desktop.mk
+sed -i 's|-lQtGui|$(shell pkg-config --libs QtGui)|' makefiles/arch/desktop.mk
+
make
make install DESTDIR=$PKG