summaryrefslogtreecommitdiffstats
path: root/office/evince/evince.SlackBuild
diff options
context:
space:
mode:
author B. Watson2020-01-01 09:31:45 +0100
committer Robby Workman2020-01-03 09:06:16 +0100
commitf0424e1e0505428c6252a46c58f737bc9341b595 (patch)
tree580ba0708a628f65152085769c98413a6bc34bc5 /office/evince/evince.SlackBuild
parent632539f0bcea4118acee65820ab72838a5e77a18 (diff)
downloadslackbuilds-f0424e1e0505428c6252a46c58f737bc9341b595.tar.gz
office/evince: Updated for version 3.28.5, new maintainer.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'office/evince/evince.SlackBuild')
-rw-r--r--office/evince/evince.SlackBuild55
1 files changed, 39 insertions, 16 deletions
diff --git a/office/evince/evince.SlackBuild b/office/evince/evince.SlackBuild
index ea4071c6eb..a1f6e48489 100644
--- a/office/evince/evince.SlackBuild
+++ b/office/evince/evince.SlackBuild
@@ -4,6 +4,7 @@
# Copyright 2009 Andrew Brouwers <abrouwers@gmail.com>
# Copyright 2009-2014, Michiel van Wessem, Manchester, United Kingdom.
+# Copyright 2019, B. Watson
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,8 +24,16 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# Now maintained by B. Watson <yalhcru@gmail.com>
+
+# 20191231 bkw:
+# - take over maintenance
+# - update for v3.28.5.3, which is the last version that will build with
+# Slack 14.2's rather outdated gtk+3 libraries. Actually it requires
+# some fugly hackery to work, see shim.h for gory details and polemic.
+
PRGNAM=evince
-VERSION=${VERSION:-3.20.2}
+VERSION=${VERSION:-3.28.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -36,8 +45,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-NLS=${NLS:-YES}
-
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
@@ -66,15 +73,15 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
# If we have any patches apply them here:
# http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/app-text/evince/files/
+# 20191231 bkw: I'll leave this here, but I have NOT tested it.
+# It was never documented in README, caveat hactor.
+NLS=${NLS:-YES}
if [ "$NLS" != "YES" ]; then
# disable NLS - we're going for a small package here.
rm po/*.po
@@ -82,6 +89,20 @@ if [ "$NLS" != "YES" ]; then
-e 's/ENABLE_NLS 1/ENABLE_NLS 0/g' configure
fi
+# 20200101 bkw: "shim" to let us actually compile with gtk+-3.18 and
+# glib-2.46.2. Supposedly these versions are supported by evince-3.28.5,
+# but upstream uses a couple of functions that are new in gtk+-3.22
+# and glib-2.52. Fortunately it's stuff we can work around with a few
+# #defines.
+SLKCFLAGS="$SLKCFLAGS -include $CWD/shim.h"
+
+# 20200101 bkw: 14.2's mime stuff identifies djvu files as
+# image/vnd.djvu only, but evince wants image/vnd.djvu+multipage.
+sed -i '/^ *DJVU_MIME_TYPES/s|="|&image/vnd.djvu;|' configure
+
+# If we were building 3.30.x, we'd need this:
+# --without-gspell \
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
@@ -99,27 +120,29 @@ CXXFLAGS="$SLKCFLAGS" \
--enable-t1lib \
--enable-comics \
--enable-dvi \
+ --enable-ps \
+ --enable-xps \
--enable-introspection \
--disable-static \
--disable-nautilus \
--disable-maintainer-mode \
+ --with-systemduserunitdir=no \
--build=$ARCH-slackware-linux
-make
-make install DESTDIR=$PKG
+# ugh. glib-genmarshal's flags changed gratuitously.
+sed -i 's,--prototypes,--header,' libview/Makefile
+
+make V=1
+make install-strip DESTDIR=$PKG
# Fix desktop entry
sed -i "/NoDisplay=true/d" $PKG/usr/share/applications/evince.desktop
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+gzip -9 $PKG/usr/man/man1/$PRGNAM.1
rm -rf $PKG/{usr/share/gtk-doc,etc}
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING NEWS README $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING NEWS README MAINTAINERS $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install