summaryrefslogtreecommitdiffstats
path: root/office/convertlit
diff options
context:
space:
mode:
author B. Watson2021-09-26 23:51:30 +0200
committer Willy Sudiarto Raharjo2021-10-12 19:52:27 +0200
commit9a2e79831ed1d1c7b7d03b6d62a96c129f01ee0d (patch)
treea0eda039bd6f52821592b4f11dfc15fbc07804ec /office/convertlit
parent06c4338844f513b6fcdf3794c6966352a652b41a (diff)
downloadslackbuilds-9a2e79831ed1d1c7b7d03b6d62a96c129f01ee0d.tar.gz
office/convertlit: Add man page, use SLKCFLAGS.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'office/convertlit')
-rw-r--r--office/convertlit/convertlit.SlackBuild20
-rw-r--r--office/convertlit/lit2epub.165
-rw-r--r--office/convertlit/lit2epub.rst52
3 files changed, 128 insertions, 9 deletions
diff --git a/office/convertlit/convertlit.SlackBuild b/office/convertlit/convertlit.SlackBuild
index 92b53ae5c0..4442fafe7c 100644
--- a/office/convertlit/convertlit.SlackBuild
+++ b/office/convertlit/convertlit.SlackBuild
@@ -11,6 +11,9 @@
# the package name, but not the actual executable. I've renamed the binary
# to convertlit to keep things SFW.
+# 20210926 bkw: BUILD=4
+# - actually use SLKCFLAGS.
+# - add man page for lit2epub.
# 20170131 bkw: BUILD=3, REQUIRES was ltm, now libtommath
cd $(dirname $0) ; CWD=$(pwd)
@@ -29,9 +32,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -68,11 +68,8 @@ mkdir -p $SRCNAME
cd $SRCNAME
unzip $CWD/$SRCNAME.zip
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
# use system-installed ltm
sed -i \
@@ -83,6 +80,9 @@ sed -i \
# update the help message to reflect the name change
sed -i '/^"/s,cl.t,'$PRGNAM,g cl?t$SRCVER/cl?t.c
+# 20210926 bkw: SLKCFLAGS weren't being used. Derp.
+sed -i "s,-O[23],$SLKCFLAGS," */Makefile
+
make -C lib
make -C cl?t$SRCVER
@@ -92,9 +92,11 @@ install -s -m0755 cl?t$SRCVER/cl?t $PKG/usr/bin/$PRGNAM
# handy wrapper script
install -m0755 $CWD/lit2epub $PKG/usr/bin
-# man page borrowed from Debian
+# convertlit man page borrowed from Debian, lit2epub written by
+# SlackBuild author.
mkdir -p $PKG/usr/man/man1
gzip -9c < $CWD/$PRGNAM.1 > $PKG/usr/man/man1/$PRGNAM.1.gz
+gzip -9c < $CWD/lit2epub.1 > $PKG/usr/man/man1/lit2epub.1.gz
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
sed 's,\r,,' cl?t$SRCVER/COPYING > $PKG/usr/doc/$PRGNAM-$VERSION/COPYING
diff --git a/office/convertlit/lit2epub.1 b/office/convertlit/lit2epub.1
new file mode 100644
index 0000000000..24d150c57a
--- /dev/null
+++ b/office/convertlit/lit2epub.1
@@ -0,0 +1,65 @@
+.\" Man page generated from reStructuredText.
+.
+.
+.nr rst2man-indent-level 0
+.
+.de1 rstReportMargin
+\\$1 \\n[an-margin]
+level \\n[rst2man-indent-level]
+level margin: \\n[rst2man-indent\\n[rst2man-indent-level]]
+-
+\\n[rst2man-indent0]
+\\n[rst2man-indent1]
+\\n[rst2man-indent2]
+..
+.de1 INDENT
+.\" .rstReportMargin pre:
+. RS \\$1
+. nr rst2man-indent\\n[rst2man-indent-level] \\n[an-margin]
+. nr rst2man-indent-level +1
+.\" .rstReportMargin post:
+..
+.de UNINDENT
+. RE
+.\" indent \\n[an-margin]
+.\" old: \\n[rst2man-indent\\n[rst2man-indent-level]]
+.nr rst2man-indent-level -1
+.\" new: \\n[rst2man-indent\\n[rst2man-indent-level]]
+.in \\n[rst2man-indent\\n[rst2man-indent-level]]u
+..
+.TH "LIT2EPUB" 1 "2021-09-26" "20160803" "SlackBuilds.org"
+.SH NAME
+lit2epub \- convert a DRM1 .lit file to .epub
+.\" RST source for lit2epub(1) man page. Convert with:
+.
+.\" rst2man.py lit2epub.rst > lit2epub.1
+.
+.\" rst2man.py comes from the SBo development/docutils package.
+.
+.SH SYNOPSIS
+.sp
+lit2epub \fBinput.lit\fP \fI[ output.epub ]\fP
+.SH DESCRIPTION
+.sp
+\fBlit2epub\fP is a wrapper script that uses \fBconvertlit\fP(1) and \fBzip\fP(1) to
+convert a DRM1 .lit ebook file to an .epub.
+.sp
+Default output file is written to the current directory, named after the
+input filename with the .lit or .LIT extension changed to .epub, or the
+input filename with .epub appended, if there is no .lit extension.
+.sp
+Use \- for the output file, to output to stdout.
+.sp
+Exit status is 0 on success, non\-zero on failure.
+.sp
+If you need to convert a non\-DRM1 .lit file, use convertlit to downconvert
+to DRM1 first.
+.SH AUTHOR
+.sp
+\fBlit2epub\fP and this man page were written for the SlackBuilds.org
+project by B. Watson, and are licensed under the WTFPL.
+.SH SEE ALSO
+.sp
+\fBconvertlit\fP(1), \fBzip\fP(1)
+.\" Generated by docutils manpage writer.
+.
diff --git a/office/convertlit/lit2epub.rst b/office/convertlit/lit2epub.rst
new file mode 100644
index 0000000000..64923fbd51
--- /dev/null
+++ b/office/convertlit/lit2epub.rst
@@ -0,0 +1,52 @@
+.. RST source for lit2epub(1) man page. Convert with:
+.. rst2man.py lit2epub.rst > lit2epub.1
+.. rst2man.py comes from the SBo development/docutils package.
+
+.. |version| replace:: 20160803
+.. |date| date::
+
+========
+lit2epub
+========
+
+---------------------------------
+convert a DRM1 .lit file to .epub
+---------------------------------
+
+:Manual section: 1
+:Manual group: SlackBuilds.org
+:Date: |date|
+:Version: |version|
+
+SYNOPSIS
+========
+
+lit2epub **input.lit** *[ output.epub ]*
+
+DESCRIPTION
+===========
+
+**lit2epub** is a wrapper script that uses **convertlit**\(1) and **zip**\(1) to
+convert a DRM1 .lit ebook file to an .epub.
+
+Default output file is written to the current directory, named after the
+input filename with the .lit or .LIT extension changed to .epub, or the
+input filename with .epub appended, if there is no .lit extension.
+
+Use - for the output file, to output to stdout.
+
+Exit status is 0 on success, non-zero on failure.
+
+If you need to convert a non-DRM1 .lit file, use convertlit to downconvert
+to DRM1 first.
+
+AUTHOR
+======
+
+**lit2epub** and this man page were written for the SlackBuilds.org
+project by B. Watson, and are licensed under the WTFPL.
+
+SEE ALSO
+========
+
+**convertlit**\(1), **zip**\(1)