summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author Andrew Clemons2022-02-06 00:41:13 +0100
committer Willy Sudiarto Raharjo2022-02-06 09:47:08 +0100
commit8f7db40f02d71cabead81b2c6b0b3060e8e164ef (patch)
tree36658e15a7ccf328a8f037c2118fce173e3c9d43 /network
parent7f2c5c5f9ba2012ad24c1bdd5cca0355c6249b27 (diff)
downloadslackbuilds-8f7db40f02d71cabead81b2c6b0b3060e8e164ef.tar.gz
network/Icecat: Removed (unmaintained, ftbfs).
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/Icecat/Icecat.SlackBuild206
-rw-r--r--network/Icecat/Icecat.desktop75
-rw-r--r--network/Icecat/Icecat.info14
-rw-r--r--network/Icecat/README6
-rw-r--r--network/Icecat/doinst.sh13
-rw-r--r--network/Icecat/gold2
-rw-r--r--network/Icecat/slack-desc19
7 files changed, 0 insertions, 335 deletions
diff --git a/network/Icecat/Icecat.SlackBuild b/network/Icecat/Icecat.SlackBuild
deleted file mode 100644
index 7c69c45713..0000000000
--- a/network/Icecat/Icecat.SlackBuild
+++ /dev/null
@@ -1,206 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for Icecat
-
-# Copyright 2008, 2009, 2010, 2011, 2012, 2013, 2014, 2015, 2016 Patrick J. Volkerding, Sebeka, Minnesota, USA
-# Copyright 2017 Azure Zanculmarktum <zanculmarktum@gmail.com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-# Almost all of the code was taken from slackware-14.2/patches/source/mozilla-firefox/
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=Icecat
-VERSION=${VERSION:-52.3.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-SRCNAM=icecat
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
- OPTIMIZE=" --enable-optimize=-O1 "
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
- OPTIMIZE=" --enable-optimize=-O1 "
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
- OPTIMIZE=" --enable-optimize=-O1 "
-elif [ "$ARCH" = "arm" ]; then
- SLKCFLAGS="-O2 -march=armv4 -mtune=xscale"
- LIBDIRSUFFIX=""
- OPTIMIZE=" --enable-optimize=-O1 "
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
- OPTIMIZE=" --enable-optimize=-O1 "
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-
-# Build and install autoconf-2.13 (like PaleMoon)
-cd $TMP
-rm -rf autoconf-2.13
-tar xvf $CWD/autoconf-2.13.tar.xz
-cd autoconf-2.13
-zcat $CWD/autoconf-2.13-consolidated_fixes-1.patch.gz | patch -p1 --verbose
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-rm -rf $TMP/autoconf-tmp
-mkdir -p $TMP/autoconf-tmp
-chmod 700 $TMP/autoconf-tmp
-rm -rf $TMP/autoconf-tmp/*
-mkdir -p $TMP/autoconf-tmp/usr
-
-./configure \
- --prefix=$TMP/autoconf-tmp/usr \
- --program-suffix=-2.13 \
- --infodir=$TMP/autoconf-tmp/usr/info \
- --mandir=$TMP/autoconf-tmp/usr/man \
- --build=$ARCH-slackware-linux
-
-make || make -j1
-make install
-PATH=$TMP/autoconf-tmp/usr/bin:$PATH
-
-# Build Icecat
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION-gnu1.tar.bz2
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# Without LANG=C, building the Python environment may fail with:
-# "UnicodeDecodeError: 'ascii' codec can't decode byte 0xe2 in position 36: ordinal not in range(128)"
-export LANG=C
-
-# Link using gold. This avoids running out of memory on 32-bit systems, and
-# avoids a recurring build failure with GNU ld on other systems.
-chmod 755 $CWD/gold
-export CC="gcc -B$CWD/gold"
-export CXX="g++ -B$CWD/gold"
-export LD="$CWD/gold"
-
-OPTIONS="\
- --enable-official-branding \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --with-default-mozilla-five-home=/usr/lib${LIBDIRSUFFIX}/icecat-$VERSION \
- --with-system-zlib \
- --enable-alsa \
- --enable-application=browser \
- --enable-default-toolkit=cairo-gtk2 \
- --enable-startup-notification \
- $OPTIMIZE \
- --enable-strip \
- --enable-cpp-rtti \
- --disable-accessibility \
- --disable-crashreporter \
- --disable-debug"
-
-export MOZILLA_OFFICIAL="1"
-export BUILD_OFFICIAL="1"
-export MOZ_PHOENIX="1"
-export MOZ_PACKAGE_JSSHELL="1"
-export CFLAGS="$SLKCFLAGS"
-export CXXFLAGS="$SLKCFLAGS"
-
-# Clear some variables that could break the build
-unset DBUS_SESSION_BUS_ADDRESS ORBIT_SOCKETDIR SESSION_MANAGER \
- XDG_SESSION_COOKIE XAUTHORITY MAKEFLAGS
-
-# Assemble our .mozconfig
-echo ". \$topsrcdir/browser/config/mozconfig" > .mozconfig
-
-# Write in it the options above
-for option in $OPTIONS; do echo "ac_add_options $option" >> .mozconfig; done
-
-echo "ac_add_options --disable-tests" >> .mozconfig
-make -f client.mk build
-
-make -f client.mk install DESTDIR=$PKG
-
-# Removes unneeded files
-rm -rf $PKG/usr/lib${LIBDIRSUFFIX}/icecat-devel-$VERSION
-rm -rf $PKG/usr/include
-
-mkdir -p $PKG/usr/share/applications
-cat $CWD/$PRGNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop
-
-# Need some default icons in the right place:
-for i in 16 22 24 32 48 256; do
- install -D -m 0644 browser/branding/official/default${i}.png \
- $PKG/usr/share/icons/hicolor/${i}x${i}/apps/icecat.png
-done
-mkdir -p $PKG/usr/share/pixmaps
-( cd $PKG/usr/share/pixmaps ; ln -sf $PKG/usr/share/icons/hicolor/256x256/apps/icecat.png . )
-install -D -m 644 browser/branding/official/default16.png \
- $PKG/usr/lib$LIBDIRSUFFIX/icecat-$VERSION/icons/default16.png
-install -D -m 644 browser/branding/official/default16.png \
- $PKG/usr/lib$LIBDIRSUFFIX/icecat-$VERSION/chrome/icons/default/default16.png
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS CLOBBER Changelog.IceCat LEGAL LICENSE README.IceCat README.txt \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/network/Icecat/Icecat.desktop b/network/Icecat/Icecat.desktop
deleted file mode 100644
index c63523edbe..0000000000
--- a/network/Icecat/Icecat.desktop
+++ /dev/null
@@ -1,75 +0,0 @@
-[Desktop Entry]
-Exec=icecat %u
-Icon=icecat
-Type=Application
-Categories=Network;
-Name=IceCat
-GenericName=Web Browser
-GenericName[af]=Web Blaaier
-GenericName[ar]=متصفح ويب
-GenericName[az]=Veb Səyyahı
-GenericName[bg]=Браузър
-GenericName[bn]=ওয়েব ব্রাউজার
-GenericName[br]=Furcher ar Gwiad
-GenericName[bs]=WWW Preglednik
-GenericName[ca]=Fullejador web
-GenericName[cs]=WWW prohlížeč
-GenericName[cy]=Porydd Gwe
-GenericName[da]=Browser
-GenericName[de]=Web-Browser
-GenericName[el]=Περιηγητής Ιστού
-GenericName[eo]=TTT-legilo
-GenericName[es]=Navegador web
-GenericName[et]=Veebilehitseja
-GenericName[eu]=Web arakatzailea
-GenericName[fa]=مرورگر وب
-GenericName[fi]=WWW-selain
-GenericName[fo]=Alnótsfar
-GenericName[fr]=Navigateur web
-GenericName[gl]=Navegador Web
-GenericName[he]=דפדפן אינטרנט
-GenericName[hi]=वेब ब्राउज़र
-GenericName[hr]=Web preglednik
-GenericName[hu]=Webböngésző
-GenericName[is]=Vafri
-GenericName[it]=Browser Web
-GenericName[ja]=ウェブブラウザ
-GenericName[ko]=웹 브라우저
-GenericName[lo]=ເວັບບຣາວເຊີ
-GenericName[lt]=Žiniatinklio naršyklė
-GenericName[lv]=Web Pārlūks
-GenericName[mk]=Прелистувач на Интернет
-GenericName[mn]=Веб-Хөтөч
-GenericName[nb]=Nettleser
-GenericName[nds]=Nettkieker
-GenericName[nl]=Webbrowser
-GenericName[nn]=Nettlesar
-GenericName[nso]=Seinyakisi sa Web
-GenericName[pa]=ਵੈਬ ਝਲਕਾਰਾ
-GenericName[pl]=Przeglądarka WWW
-GenericName[pt]=Navegador Web
-GenericName[pt_BR]=Navegador Web
-GenericName[ro]=Navigator de web
-GenericName[ru]=Веб-браузер
-GenericName[se]=Fierpmádatlogan
-GenericName[sk]=Webový prehliadač
-GenericName[sl]=Spletni brskalnik
-GenericName[sr]=Веб претраживач
-GenericName[sr@Latn]=Veb pretraživač
-GenericName[ss]=Ibrawuza yeWeb
-GenericName[sv]=Webbläsare
-GenericName[ta]=வலை உலாவி
-GenericName[tg]=Тафсиргари вэб
-GenericName[th]=เว็บบราวเซอร์
-GenericName[tr]=Web Tarayıcı
-GenericName[uk]=Навігатор Тенет
-GenericName[uz]=Веб-браузер
-GenericName[ven]=Buronza ya Webu
-GenericName[vi]=Trình duyệt Web
-GenericName[wa]=Betchteu waibe
-GenericName[xh]=Umkhangeli zincwadi we Web
-GenericName[zh_CN]=网页浏览器
-GenericName[zh_TW]=網頁瀏覽器
-GenericName[zu]=Umcingi we-Web
-MimeType=text/html;text/xml;application/xhtml+xml;application/vnd.mozilla.xul+xml;text/mml;x-scheme-handler/http;x-scheme-handler/https;
-X-KDE-StartupNotify=true
diff --git a/network/Icecat/Icecat.info b/network/Icecat/Icecat.info
deleted file mode 100644
index 62e08aa3ae..0000000000
--- a/network/Icecat/Icecat.info
+++ /dev/null
@@ -1,14 +0,0 @@
-PRGNAM="Icecat"
-VERSION="52.3.0"
-HOMEPAGE="http://www.gnu.org/software/gnuzilla/"
-DOWNLOAD="http://ftp.gnu.org/gnu/gnuzilla/52.3.0/icecat-52.3.0-gnu1.tar.bz2\
- http://ponce.cc/slackware/sources/repo/autoconf-2.13.tar.xz \
- http://ponce.cc/slackware/sources/repo/autoconf-2.13-consolidated_fixes-1.patch.gz"
-MD5SUM="67f1ecc240c4f2624c935c5300392260 \
- f2994d302cf736e7e71974edfa51da3c \
- d6cdb231911a8d0b08a25b8dd8c5935c"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Azure Zanculmarktum"
-EMAIL="zanculmarktum@gmail.com"
diff --git a/network/Icecat/README b/network/Icecat/README
deleted file mode 100644
index b747d3c556..0000000000
--- a/network/Icecat/README
+++ /dev/null
@@ -1,6 +0,0 @@
-GNU IceCat is the GNU version of the Firefox browser. Its main advantage
-is an ethical one: it is entirely free software.
-
-This SlackBuild builds the entire project from source. To use the
-upstream binary, see the 'icecat' SlackBuild. Please uninstall 'icecat'
-before running this SlackBuild.
diff --git a/network/Icecat/doinst.sh b/network/Icecat/doinst.sh
deleted file mode 100644
index aea0f894eb..0000000000
--- a/network/Icecat/doinst.sh
+++ /dev/null
@@ -1,13 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
-
-if [ -x /usr/bin/update-mime-database ]; then
- /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
-fi
-
-if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
- if [ -x /usr/bin/gtk-update-icon-cache ]; then
- /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
- fi
-fi
diff --git a/network/Icecat/gold b/network/Icecat/gold
deleted file mode 100644
index 7b02884de2..0000000000
--- a/network/Icecat/gold
+++ /dev/null
@@ -1,2 +0,0 @@
-#!/bin/sh
-/usr/bin/ld.gold "$@"
diff --git a/network/Icecat/slack-desc b/network/Icecat/slack-desc
deleted file mode 100644
index 6103f6a488..0000000000
--- a/network/Icecat/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-Icecat: Icecat (GNU version of the Firefox browser)
-Icecat:
-Icecat: GNU IceCat is the GNU version of the Firefox browser. Its main
-Icecat: advantage is an ethical one: it is entirely free software.
-Icecat:
-Icecat:
-Icecat:
-Icecat:
-Icecat:
-Icecat:
-Icecat: