summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author abooksigun2019-09-28 02:55:18 +0200
committer Willy Sudiarto Raharjo2019-09-28 02:55:18 +0200
commitbe961228fecae28c7cf41f000a55c2118ab59ea8 (patch)
tree0613c68dbade8b131b93f34e3f8cc3c60842aba5 /network
parentffc8a714e72a7d3cc599254a23bd663be28a2796 (diff)
downloadslackbuilds-be961228fecae28c7cf41f000a55c2118ab59ea8.tar.gz
network/urlscan: Added (Browser Launcher for mutt).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/urlscan/README27
-rw-r--r--network/urlscan/slack-desc19
-rw-r--r--network/urlscan/urlscan.SlackBuild91
-rw-r--r--network/urlscan/urlscan.info10
4 files changed, 147 insertions, 0 deletions
diff --git a/network/urlscan/README b/network/urlscan/README
new file mode 100644
index 0000000000..b108ec74b6
--- /dev/null
+++ b/network/urlscan/README
@@ -0,0 +1,27 @@
+
+Urlscan parses an email message or file and scans it for URLs and email addresses.
+It then displays the URLs and their context within the message,
+and allows you to choose one or more URLs to send to your Web browser.
+Alternatively, it send a list of all URLs to stdout.
+
+Relative to urlview, urlscan has the following additional features:
+
+* Support for emails in quoted-printable and base64 encodings.
+ No more stripping out =40D from URLs by hand!
+* The context of each URL is provided along with the URL.
+ For HTML mails, a crude parser is used to render the HTML into text.
+ Context view can be toggled on/off with c.
+* URLs are shortened by default to fit on one line.
+ Viewing full URL (for one or all) is toggled with s or S.
+* Jump to a URL by typing the number.
+* Incremental case-insensitive search with /.
+* Execute an arbitrary function (for example, copy URL to clipboard)
+ instead of opening URL in a browser.
+* Use l to cycle through whether URLs are opened using the Python webbrowser module (default),
+ xdg-open (if installed) or opened by a function passed on the command line with --run.
+* Configure colors and keybindings via ~/.config/urlscan/config.json.
+ Generate default config file for editing by running urlscan -g.
+ Cycle through available palettes with p.
+* Copy URL to clipboard with C or to primary selection with P. Requires xsel or xclip.
+* Run a command with the selected URL as the argument or pipe the selected URL to a command.
+* Show complete help menu with F1. Hide header on startup with --nohelp.
diff --git a/network/urlscan/slack-desc b/network/urlscan/slack-desc
new file mode 100644
index 0000000000..89995441c0
--- /dev/null
+++ b/network/urlscan/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+urlscan: urlscan (Replacement for urlview, a web browser launcher for mutt)
+urlscan:
+urlscan: Urlscan is a small program that is designed
+urlscan: to integrate with the "mutt" mailreader to allow you to easily
+urlscan: launch a Web browser for URLs contained in email messages.
+urlscan: It is a replacement for the "urlview" program.
+urlscan:
+urlscan:
+urlscan:
+urlscan:
+urlscan:
diff --git a/network/urlscan/urlscan.SlackBuild b/network/urlscan/urlscan.SlackBuild
new file mode 100644
index 0000000000..53135d4c57
--- /dev/null
+++ b/network/urlscan/urlscan.SlackBuild
@@ -0,0 +1,91 @@
+#!/bin/sh
+
+# Slackware build script for urlscan
+# Copyright 2019 abooksigun <abooksigun09@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=urlscan
+VERSION=${VERSION:-0.9.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG --optimize=1
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+cp -r $PKG/usr/share/man $PKG/usr
+rm -r $PKG/usr/share
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -t $PKG/usr/doc/$PRGNAM-$VERSION README.rst COPYING requirements.txt
+
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/urlscan/urlscan.info b/network/urlscan/urlscan.info
new file mode 100644
index 0000000000..dd9689a567
--- /dev/null
+++ b/network/urlscan/urlscan.info
@@ -0,0 +1,10 @@
+PRGNAM="urlscan"
+VERSION="0.9.4"
+HOMEPAGE="https://github.com/firecat53/urlscan"
+DOWNLOAD="https://github.com/firecat53/urlscan/archive/0.9.4/urlscan-0.9.4.tar.gz"
+MD5SUM="5c735bbb872248f0d981b4efcde257ac"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-urwid"
+MAINTAINER="abooksigun"
+EMAIL="abooksigun09@gmail.com"