summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author B. Watson2018-08-27 20:16:35 +0200
committer Willy Sudiarto Raharjo2018-09-01 02:32:28 +0200
commit16bc40f500ca0e616dcbce4dce62423ea958ac8d (patch)
tree28e5980c12dba62267a257a80272612f6c5b29d0 /network
parent843e3bb5332fd2c0037df9c73fbb018394f39c20 (diff)
downloadslackbuilds-16bc40f500ca0e616dcbce4dce62423ea958ac8d.tar.gz
network/2ping: Updated for version 4.2.
Signed-off-by: B. Watson <yalhcru@gmail.com>
Diffstat (limited to 'network')
-rw-r--r--network/2ping/2ping.SlackBuild25
-rw-r--r--network/2ping/2ping.info6
-rw-r--r--network/2ping/README14
3 files changed, 35 insertions, 10 deletions
diff --git a/network/2ping/2ping.SlackBuild b/network/2ping/2ping.SlackBuild
index bdb398e8f5..263ffa123b 100644
--- a/network/2ping/2ping.SlackBuild
+++ b/network/2ping/2ping.SlackBuild
@@ -6,8 +6,13 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20180821 bkw:
+# - update for v4.2.
+# - document optional deps in README.
+# - include wireshark stuff in package.
+
PRGNAM=2ping
-VERSION=${VERSION:-4.1}
+VERSION=${VERSION:-4.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -41,18 +46,24 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
python3 setup.py install --root=$PKG
+# Include wireshark stuff, if we have a wireshark that can use it (built
+# with lua52). The lua script is for decoding, the .pcap file is a sample
+# packet capture (belongs in doc dir).
+if [ -x /usr/bin/wireshark ] && ldd /usr/bin/wireshark | fgrep -q lua5.2; then
+ mkdir -p $PKG/usr/lib$LIBDIRSUFFIX/wireshark/plugins
+ cp -a wireshark/*.lua $PKG/usr/lib$LIBDIRSUFFIX/wireshark/plugins
+fi
+
mkdir -p $PKG/usr/man/man1
gzip -9c < doc/$PRGNAM.1 > $PKG/usr/man/man1/$PRGNAM.1.gz
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/wireshark
cp -a README* COPYING ChangeLog doc/*.py doc/*.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a wireshark/*.pcap $PKG/usr/doc/$PRGNAM-$VERSION/wireshark
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/network/2ping/2ping.info b/network/2ping/2ping.info
index 168ab6554a..2cc7f5188f 100644
--- a/network/2ping/2ping.info
+++ b/network/2ping/2ping.info
@@ -1,8 +1,8 @@
PRGNAM="2ping"
-VERSION="4.1"
+VERSION="4.2"
HOMEPAGE="https://www.finnie.org/software/2ping/"
-DOWNLOAD="https://github.com/rfinnie/2ping/archive/v4.1/2ping-4.1.tar.gz"
-MD5SUM="826a626bd8ac85fddaa7f54f87d7fc19"
+DOWNLOAD="https://github.com/rfinnie/2ping/archive/v4.2/2ping-4.2.tar.gz"
+MD5SUM="5be6bdc3a35c1592133642ea80c0e63e"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python3"
diff --git a/network/2ping/README b/network/2ping/README
index 7a2c7f1f07..59335bc9b2 100644
--- a/network/2ping/README
+++ b/network/2ping/README
@@ -15,3 +15,17 @@ If you want to start a listener at boot, add a command like this to
/etc/rc.d/rc.local:
su nobody -s /bin/sh -c 'exec /usr/bin/2ping --quiet --listen' &> /dev/null &
+
+Optional dependencies: Certain command line options to 2ping require
+additional packages.
+
+- dnspython (built after python3 is installed): --srv option.
+- netifaces (built with PYTHON3=yes): --all-interfaces option.
+- python3-pycrypto: --encrypt option.
+
+The package can include a wireshark plugin for decoding the 2ping
+protocol. This requires your wireshark to have been compiled with lua52
+(not lua, which is version 5.1). See the README for network/wireshark
+for details. If you're not sure about your wireshark's lua version, try
+"ldd /usr/bin/wireshark|grep lua". This will show either liblua.so.5.1
+or liblua.so.5.2.