summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author B. Watson2022-03-23 02:51:47 +0100
committer Willy Sudiarto Raharjo2022-03-25 19:20:10 +0100
commit166783a0b1908e845a3122476726fc555db7a560 (patch)
tree907fc742bfe914bccf84c7a6aaf40f90b280b497 /network
parent7c0ed7b6a864bfe02ee14e33f12b3b1e7211ad1a (diff)
downloadslackbuilds-166783a0b1908e845a3122476726fc555db7a560.tar.gz
network/heimdal: Fix 32-bit build.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/heimdal/heimdal.SlackBuild17
1 files changed, 12 insertions, 5 deletions
diff --git a/network/heimdal/heimdal.SlackBuild b/network/heimdal/heimdal.SlackBuild
index 70c15e2342..5d08b5fddf 100644
--- a/network/heimdal/heimdal.SlackBuild
+++ b/network/heimdal/heimdal.SlackBuild
@@ -23,6 +23,8 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220322 bkw: Modified by SlackBuilds.org: fix 32-bit build.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=heimdal
@@ -39,9 +41,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -76,9 +75,17 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+
+# 20220322 bkw: disable 2 of the unit tests that won't work on 32-bit,
+# because they rely on pre-generated certificates whose expiration
+# dates are ~500 years in the future (meaning past 2038, meaning a
+# 32-bit time_t can't handle it). This has been a known issue upstream
+# since at least 2019: https://github.com/heimdal/heimdal/issues/533
+[ -z "$LIBDIRSUFFIX" ] && \
+ sed -i '/^[\t ]*test_c\(hain\|ms\)[\t ]/d' lib/hx509/Makefile.??
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \