summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author B. Watson2020-11-27 20:56:44 +0100
committer Willy Sudiarto Raharjo2020-11-28 19:02:52 +0100
commitc2ac841dcf3b5e7f2cb78aee62e9b662e2f1d2d4 (patch)
tree68d23f2fe83caa658eb5af2fac5936fa4eab1f66 /network
parent17d911717e0fc92df04c32b9d3c2f4fb1fd2b561 (diff)
downloadslackbuilds-c2ac841dcf3b5e7f2cb78aee62e9b662e2f1d2d4.tar.gz
network/ircII: Added (IRC Client, Second Edition)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/ircII/README14
-rw-r--r--network/ircII/ircII.SlackBuild132
-rw-r--r--network/ircII/ircII.info12
-rw-r--r--network/ircII/slack-desc19
4 files changed, 177 insertions, 0 deletions
diff --git a/network/ircII/README b/network/ircII/README
new file mode 100644
index 0000000000..330bfe39e2
--- /dev/null
+++ b/network/ircII/README
@@ -0,0 +1,14 @@
+ircII (IRC Client, Second Edition)
+
+ircII is a full screen, curses-based interface to Internet Relay
+Chat. It gives full access to all of the normal IRC functions, plus a
+variety of additional options.
+
+ircII is the oldest IRC client still maintained.
+
+By default, this SlackBuild sets the default IRC server to
+"SSLIRC/chat.freenode.org:6697". This only applies with ircII is
+run without a server argument on the command line. You can change
+the default server by setting the DEFSRV environment variable to the
+host:port (with optional SSLIRC/ prefix for a secure connection), or
+compile without a default server with DEFSRV=none.
diff --git a/network/ircII/ircII.SlackBuild b/network/ircII/ircII.SlackBuild
new file mode 100644
index 0000000000..917a708aff
--- /dev/null
+++ b/network/ircII/ircII.SlackBuild
@@ -0,0 +1,132 @@
+#!/bin/sh
+
+# Slackware build script for ircII
+
+# Written by B. Watson (yalhcru@gmail.com)
+
+# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+
+# I don't know why nobody's already done a SlackBuild for this.
+# Normally I prefer all-lowercase package names, but this just looks
+# *wrong* as "ircii".
+
+PRGNAM=ircII
+VERSION=${VERSION:-20190117_1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM=${PRGNAM,,}
+SRCVER=${VERSION%_*}
+DEBVER=${VERSION#*_}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+DEFSRV="${DEFSRV:-SSLIRC/chat.freenode.org:6697}"
+case "$DEFSRV" in
+ none|NONE) ;;
+ *:*) srvopt="--with-default-server=$DEFSRV" ;;
+ *) echo "$0: invalid DEFSRV, use host:port, SSLIRC/host:port, or 'none'" 1>&2
+ exit 1 ;;
+esac
+
+echo "=== DEFSRV='$DEFSRV', srvopt='$srvopt'"
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$SRCVER
+tar xvf $CWD/$SRCNAM-$SRCVER.tar.gz
+cd $SRCNAM-$SRCVER
+tar xvf $CWD/${SRCNAM}_$SRCVER-$DEBVER.debian.tar.xz
+chown -R root:root .
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
+
+# apply most of Debian's patches.
+rm -f debian/patches/0004-absolute-path*
+for i in $( cat debian/patches/series ); do
+ [ -e debian/patches/$i ] && patch -p1 < debian/patches/$i
+done
+
+# fix warnings caused by missing includes.
+sed -i -e '1i#include <curses.h>' \
+ -e '1i#include <term.h>' \
+ source/term.c
+
+# do not compile with termcap. there's no --disable-termcap or similar,
+# have to do surgery.
+sed -i -e '/AC_CHECK_LIB(termcap/s,termcap,ncurses,g' \
+ -e 's,termcap\.h ,,' \
+ configure.in
+autoreconf -ifv
+
+# is there a disadvantage to enabling emacs meta keys?
+CFLAGS="$SLKCFLAGS -Wl,-s" \
+CXXFLAGS="$SLKCFLAGS -Wl,-s" \
+./configure \
+ $srvopt \
+ --with-emacs-meta-keys \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --build=$ARCH-slackware-linux
+
+make
+
+# make install doesn't create this dir, and doesn't respect DESTDIR
+# for the man dir.
+mkdir -p $PKG/usr/man/man1
+make install DESTDIR=$PKG mandir=$PKG/usr/man/man1
+
+# package called ircII, so let's have an ircII executable.
+ln -s irc-$VERSION $PKG/usr/bin/$PRGNAM
+
+rm -f $PKG/usr/man/man1/irc.1
+gzip -9 $PKG/usr/man/man1/*.1
+ln -s ircII.1.gz $PKG/usr/man/man1/irc.1.gz
+
+# Debian includes some extra man pages
+for i in debian/*.1; do
+ gzip -9c < $i > $PKG/usr/man/man1/$( basename $i ).gz
+done
+
+rm -f doc/*.1 doc/*.spec*
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a ChangeLog NEWS README doc/* contrib $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/ircII/ircII.info b/network/ircII/ircII.info
new file mode 100644
index 0000000000..241b6c6e91
--- /dev/null
+++ b/network/ircII/ircII.info
@@ -0,0 +1,12 @@
+PRGNAM="ircII"
+VERSION="20190117_1"
+HOMEPAGE="http://www.eterna.com.au/ircii/"
+DOWNLOAD="http://ircii.warped.com/ircii-20190117.tar.gz \
+ http://deb.debian.org/debian/pool/main/i/ircii/ircii_20190117-1.debian.tar.xz"
+MD5SUM="f0ca9ade8aa068acddbe15b215c0b22a \
+ 6d077f10fb7133141d9e6bcba4ad0314"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="B. Watson"
+EMAIL="yalhcru@gmail.com"
diff --git a/network/ircII/slack-desc b/network/ircII/slack-desc
new file mode 100644
index 0000000000..7086e8cd94
--- /dev/null
+++ b/network/ircII/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+ircII: ircII (IRC Client, Second Edition)
+ircII:
+ircII: ircII is a full screen, curses-based interface to Internet Relay
+ircII: Chat. It gives full access to all of the normal IRC functions, plus a
+ircII: variety of additional options.
+ircII:
+ircII: ircII is the oldest IRC client still maintained.
+ircII:
+ircII:
+ircII:
+ircII: