summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author Erich Ritz2020-11-14 00:23:13 +0100
committer Willy Sudiarto Raharjo2020-11-14 11:16:40 +0100
commit23beae9f9d9d4755f68ffa77b03e23dca4cdf17b (patch)
treebe5351112338e3107205987116400018321b70ab /network
parent6f0305acc4e6191691ef33f701c4198600b0ece3 (diff)
downloadslackbuilds-23beae9f9d9d4755f68ffa77b03e23dca4cdf17b.tar.gz
network/protonvpn-cli: Added (ProtonVPN's Linux CLI)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/protonvpn-cli/README26
-rw-r--r--network/protonvpn-cli/protonvpn-cli.SlackBuild72
-rw-r--r--network/protonvpn-cli/protonvpn-cli.info10
-rw-r--r--network/protonvpn-cli/slack-desc19
4 files changed, 127 insertions, 0 deletions
diff --git a/network/protonvpn-cli/README b/network/protonvpn-cli/README
new file mode 100644
index 0000000000..fb79f036ca
--- /dev/null
+++ b/network/protonvpn-cli/README
@@ -0,0 +1,26 @@
+protonvpn-cli is the official Linux command line tool for connecting to
+the ProtonVPN. It is a full rewrite of the original bash protonvpn-cli
+in Python, which adds more features and functionality with the purpose
+of improving readability, speed, and reliability.
+
+Before using protonvpn-cli, it must be initialized. Run (as root)
+
+ protonvpn init
+
+and follow the prompts on the screen. Your OpenVPN username and password
+can be found at https://account.protonvpn.com/account. Note that both
+free and paid accounts are supported.
+
+After protonvpn-cli is configured, run (as root)
+
+ protonvpn connect -f
+
+to connect to ProtonVPN using the fastest available server.
+
+Before uninstalling, run
+
+ protonvpn configure
+
+to purge the configuration files.
+
+All dependencies must be built with Python3 support.
diff --git a/network/protonvpn-cli/protonvpn-cli.SlackBuild b/network/protonvpn-cli/protonvpn-cli.SlackBuild
new file mode 100644
index 0000000000..c1730a5774
--- /dev/null
+++ b/network/protonvpn-cli/protonvpn-cli.SlackBuild
@@ -0,0 +1,72 @@
+#!/bin/sh
+
+# Slackware build script for protonvpn-cli
+
+# Copyright 2019-2020 Erich Ritz, Scottsdale, Arizona, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=protonvpn-cli
+SRCNAM=linux-cli
+VERSION=${VERSION:-2.2.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+# Unless $ARCH is already set, use uname -m for all other archs:
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS CHANGELOG.md LICENSE README.md USAGE.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/protonvpn-cli/protonvpn-cli.info b/network/protonvpn-cli/protonvpn-cli.info
new file mode 100644
index 0000000000..bdeaa7f77b
--- /dev/null
+++ b/network/protonvpn-cli/protonvpn-cli.info
@@ -0,0 +1,10 @@
+PRGNAM="protonvpn-cli"
+VERSION="2.2.4"
+HOMEPAGE="https://protonvpn.com/support/linux-vpn-tool/"
+DOWNLOAD="https://github.com/ProtonVPN/linux-cli/archive/v2.2.4/linux-cli-2.2.4.tar.gz"
+MD5SUM="73441f4b431623beb94775b86c1c8af0"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3 docopt python-requests python3-pythondialog Jinja2"
+MAINTAINER="Erich Ritz"
+EMAIL="erich.public@protonmail.com"
diff --git a/network/protonvpn-cli/slack-desc b/network/protonvpn-cli/slack-desc
new file mode 100644
index 0000000000..db0231542f
--- /dev/null
+++ b/network/protonvpn-cli/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+protonvpn-cli: protonvpn-cli (ProtonVPN's Linux Command-Line Interface)
+protonvpn-cli:
+protonvpn-cli: Official Linux command line tool for connection to the ProtonVPN. It
+protonvpn-cli: is a full rewrite of the original bash protonvpn-cli in Python, which
+protonvpn-cli: adds more features and functionality with the purpose of improving
+protonvpn-cli: readability, speed, and reliability.
+protonvpn-cli:
+protonvpn-cli: Homepage: https://protonvpn.com/support/linux-vpn-tool/
+protonvpn-cli:
+protonvpn-cli:
+protonvpn-cli: