summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author abooksigun2020-09-03 19:13:26 +0200
committer Willy Sudiarto Raharjo2020-09-03 19:13:26 +0200
commitb4367f687082fa6075bb3d5819d5195211b88b69 (patch)
tree45eb5b5ac270924b3de45073a1313b1b4575888e /network
parent9085ab38db463c85b7e4dd4a722b8b8e1cd9d6a9 (diff)
downloadslackbuilds-b4367f687082fa6075bb3d5819d5195211b88b69.tar.gz
network/urlscan: Updated for version 0.9.5.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/urlscan/urlscan.SlackBuild22
-rw-r--r--network/urlscan/urlscan.info6
2 files changed, 17 insertions, 11 deletions
diff --git a/network/urlscan/urlscan.SlackBuild b/network/urlscan/urlscan.SlackBuild
index 53135d4c57..3ab9b11d11 100644
--- a/network/urlscan/urlscan.SlackBuild
+++ b/network/urlscan/urlscan.SlackBuild
@@ -1,7 +1,7 @@
#!/bin/sh
# Slackware build script for urlscan
-# Copyright 2019 abooksigun <abooksigun09@gmail.com>
+# Copyright 2020 abooksigun <abooksigun09@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,7 +22,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=urlscan
-VERSION=${VERSION:-0.9.4}
+VERSION=${VERSION:-0.9.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -63,10 +63,10 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
python3 setup.py install --root=$PKG --optimize=1
@@ -76,8 +76,14 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
cp -r $PKG/usr/share/man $PKG/usr
rm -r $PKG/usr/share
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+for man in $( find $PKG/usr/man -type f ); do
+ gzip -9 $man
+done
+
+for man in $( find $PKG/usr/man -type l ); do
+ ln -s $( readlink $man ).gz $man.gz
+ rm $man
+done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -t $PKG/usr/doc/$PRGNAM-$VERSION README.rst COPYING requirements.txt
diff --git a/network/urlscan/urlscan.info b/network/urlscan/urlscan.info
index dd9689a567..8ca34f658a 100644
--- a/network/urlscan/urlscan.info
+++ b/network/urlscan/urlscan.info
@@ -1,8 +1,8 @@
PRGNAM="urlscan"
-VERSION="0.9.4"
+VERSION="0.9.5"
HOMEPAGE="https://github.com/firecat53/urlscan"
-DOWNLOAD="https://github.com/firecat53/urlscan/archive/0.9.4/urlscan-0.9.4.tar.gz"
-MD5SUM="5c735bbb872248f0d981b4efcde257ac"
+DOWNLOAD="https://github.com/firecat53/urlscan/archive/0.9.5/urlscan-0.9.5.tar.gz"
+MD5SUM="6b9434208dbcfd12dd4dde74b4b41b21"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python3-urwid"