summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author Marek Wodzinski2020-01-23 21:52:18 +0100
committer Willy Sudiarto Raharjo2020-01-24 20:54:59 +0100
commita1cbb9d55171f9913d5c1ebdb957075122937b1f (patch)
tree76b831611459192d368d8088a72737598d80f165 /network
parent0d34bc0c736e92bb294cacf61a79a68280780afc (diff)
downloadslackbuilds-a1cbb9d55171f9913d5c1ebdb957075122937b1f.tar.gz
network/ipvsadm: Updated for version 1.31.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/ipvsadm/ipvsadm-1.25-popt.patch19
-rw-r--r--network/ipvsadm/ipvsadm.SlackBuild21
-rw-r--r--network/ipvsadm/ipvsadm.info6
3 files changed, 15 insertions, 31 deletions
diff --git a/network/ipvsadm/ipvsadm-1.25-popt.patch b/network/ipvsadm/ipvsadm-1.25-popt.patch
deleted file mode 100644
index 2826002843..0000000000
--- a/network/ipvsadm/ipvsadm-1.25-popt.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-diff -Naupr ipvsadm-1.25.orig/Makefile ipvsadm-1.25/Makefile
---- ipvsadm-1.25.orig/Makefile 2008-09-23 18:14:46.000000000 +0200
-+++ ipvsadm-1.25/Makefile 2008-12-22 20:03:53.793372130 +0100
-@@ -62,14 +62,7 @@ RPMBUILD = $(shell \
- fi )
-
- ifeq (,$(FORCE_GETOPT))
--LIB_SEARCH = /lib /usr/lib /usr/local/lib
--POPT_LIB = $(shell for i in $(LIB_SEARCH); do \
-- if [ -f $$i/libpopt.a ]; then \
-- if nm $$i/libpopt.a | fgrep -q poptGetContext; then \
-- echo "-lpopt"; \
-- fi; \
-- fi; \
--done)
-+POPT_LIB = "-lpopt"
- endif
-
- ifneq (,$(POPT_LIB))
diff --git a/network/ipvsadm/ipvsadm.SlackBuild b/network/ipvsadm/ipvsadm.SlackBuild
index 6dfcb5dbd4..859dc91841 100644
--- a/network/ipvsadm/ipvsadm.SlackBuild
+++ b/network/ipvsadm/ipvsadm.SlackBuild
@@ -1,12 +1,12 @@
#!/bin/sh
-# Slackware build script for source-highlight
-# Written by luoyi (luoyi.ly@gmail.com)
-
-# Modified by the slackbuilds.org project
+# Slackware build script for ipvsadm
+# 2010 - Written by luoyi (luoyi.ly@gmail.com)
+# 2010-2016 - Modified by the slackbuilds.org project
+# 2020 - Modified by Marek Wodzinski <majek@w7i.pl>
PRGNAM=ipvsadm
-VERSION=${VERSION:-1.25}
+VERSION=${VERSION:-1.31}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -43,7 +43,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -52,9 +52,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# fix not detecting popt by default
-patch -p1 -i $CWD/ipvsadm-1.25-popt.patch
-
# use SLKCFLAGS
sed -i "s/-Wall/-Wall $SLKCFLAGS/" Makefile
sed -i "s/-Wall/-Wall $SLKCFLAGS/" libipvs/Makefile
@@ -72,8 +69,14 @@ find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
)
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ MAINTAINERS README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+mv $PKG/etc/rc.d/init.d/ipvsadm $PKG/etc/rc.d/rc.ipvsadm
+rmdir $PKG/etc/rc.d/init.d
+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/network/ipvsadm/ipvsadm.info b/network/ipvsadm/ipvsadm.info
index 41c49d96ab..13e862d990 100644
--- a/network/ipvsadm/ipvsadm.info
+++ b/network/ipvsadm/ipvsadm.info
@@ -1,8 +1,8 @@
PRGNAM="ipvsadm"
-VERSION="1.25"
+VERSION="1.31"
HOMEPAGE="http://www.linuxvirtualserver.org/"
-DOWNLOAD="http://www.linuxvirtualserver.org/software/kernel-2.6/ipvsadm-1.25.tar.gz"
-MD5SUM="772a053f5fe888cd25784c5f55d31fc3"
+DOWNLOAD="https://mirrors.edge.kernel.org/pub/linux/utils/kernel/ipvsadm/ipvsadm-1.31.tar.xz"
+MD5SUM="f6d1707c5baf684b58fd33682d67871f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""