summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author David Spencer2017-08-11 01:10:13 +0200
committer Willy Sudiarto Raharjo2017-08-12 01:58:32 +0200
commit7f804926b3c2bfece7500846f185a493faa8c0e6 (patch)
treea336c874b493c44265171b170dcced73594eabb3 /network
parentbf1a15a9c7ed7e9951d64dd09092f6d12cf0a858 (diff)
downloadslackbuilds-7f804926b3c2bfece7500846f185a493faa8c0e6.tar.gz
network/WireGuard: Added (fast, modern, secure VPN).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/WireGuard/README7
-rw-r--r--network/WireGuard/WireGuard.SlackBuild105
-rw-r--r--network/WireGuard/WireGuard.info10
-rw-r--r--network/WireGuard/doinst.sh3
-rw-r--r--network/WireGuard/slack-desc19
5 files changed, 144 insertions, 0 deletions
diff --git a/network/WireGuard/README b/network/WireGuard/README
new file mode 100644
index 0000000000..2077fd7f13
--- /dev/null
+++ b/network/WireGuard/README
@@ -0,0 +1,7 @@
+WireGuard is a VPN that uses state-of-the-art cryptography. It is
+designed as a general purpose VPN for running on embedded interfaces
+and super computers alike, fit for many different circumstances.
+
+WireGuard is not yet complete. You should not rely on this code. It has
+not undergone proper degrees of security auditing and the protocol is
+still subject to change.
diff --git a/network/WireGuard/WireGuard.SlackBuild b/network/WireGuard/WireGuard.SlackBuild
new file mode 100644
index 0000000000..89e26a2f77
--- /dev/null
+++ b/network/WireGuard/WireGuard.SlackBuild
@@ -0,0 +1,105 @@
+#!/bin/sh
+
+# Slackware build script for WireGuard
+
+# Copyright 2017 David Spencer, Baildon, West Yorkshire, U.K.
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=WireGuard
+VERSION=${VERSION:-0.0.20170810}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+KERNEL="${KERNEL:-"$(uname -r)"}"
+PKGVER="$(printf %s "${VERSION}_$KERNEL" | tr - _)"
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -ex
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# We do this in doinst.sh
+sed -i -e '/depmod -a/d' src/Makefile
+
+# If you want this, you can have it :)
+SYSTEMD="${SYSTEMD:-no}"
+
+cd src
+ CFLAGS="$SLKCFLAGS" make
+ make install \
+ MANDIR=/usr/man \
+ DESTDIR=$PKG \
+ INSTALL_MOD_PATH=$PKG \
+ WITH_SYSTEMDUNITS="$SYSTEMD"
+cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$PKGVER
+cp -a COPYING README.md contrib/examples $PKG/usr/doc/$PRGNAM-$PKGVER
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$PKGVER/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+sed "s%@KERNEL@%$KERNEL%" $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$PKGVER-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/WireGuard/WireGuard.info b/network/WireGuard/WireGuard.info
new file mode 100644
index 0000000000..61f29abaec
--- /dev/null
+++ b/network/WireGuard/WireGuard.info
@@ -0,0 +1,10 @@
+PRGNAM="WireGuard"
+VERSION="0.0.20170810"
+HOMEPAGE="https://www.wireguard.com/"
+DOWNLOAD="https://git.zx2c4.com/WireGuard/snapshot/WireGuard-0.0.20170810.tar.xz"
+MD5SUM="8dd3e080407b8295c25565a847a4ca27"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="David Spencer"
+EMAIL="baildon.research@googlemail.com"
diff --git a/network/WireGuard/doinst.sh b/network/WireGuard/doinst.sh
new file mode 100644
index 0000000000..d335d682c8
--- /dev/null
+++ b/network/WireGuard/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x sbin/depmod ]; then
+ chroot . /sbin/depmod -a @KERNEL@ 1> /dev/null 2> /dev/null
+fi
diff --git a/network/WireGuard/slack-desc b/network/WireGuard/slack-desc
new file mode 100644
index 0000000000..1605ab22e1
--- /dev/null
+++ b/network/WireGuard/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+WireGuard: WireGuard (fast, modern, secure VPN)
+WireGuard:
+WireGuard: WireGuard is a VPN that uses state-of-the-art cryptography. It is
+WireGuard: designed as a general purpose VPN for running on embedded interfaces
+WireGuard: and super computers alike, fit for many different circumstances.
+WireGuard:
+WireGuard: https://www.wireguard.com/
+WireGuard:
+WireGuard:
+WireGuard:
+WireGuard: