summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author B. Watson2017-08-27 18:21:18 +0200
committer David Spencer2017-09-02 11:19:44 +0200
commit2d3140cce7905c21ceae9e5b2cae5ea008b7a77a (patch)
treead69d38f43859ae4280a4b8f3bd8b6b92153851b /network
parent3f1c9977ed71ce604e3879165c9849eb04f7da4f (diff)
downloadslackbuilds-2d3140cce7905c21ceae9e5b2cae5ea008b7a77a.tar.gz
network/2ping: Added (bi-directional ping utility).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/2ping/2ping.SlackBuild61
-rw-r--r--network/2ping/2ping.info10
-rw-r--r--network/2ping/README17
-rw-r--r--network/2ping/slack-desc19
4 files changed, 107 insertions, 0 deletions
diff --git a/network/2ping/2ping.SlackBuild b/network/2ping/2ping.SlackBuild
new file mode 100644
index 0000000000..bdb398e8f5
--- /dev/null
+++ b/network/2ping/2ping.SlackBuild
@@ -0,0 +1,61 @@
+#!/bin/sh
+
+# Slackware build script for 2ping
+
+# Written by B. Watson (yalhcru@gmail.com)
+
+# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+
+PRGNAM=2ping
+VERSION=${VERSION:-4.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+# This could be a noarch package, except python libs are installed
+# to /usr/lib64 on x86_64 and /usr/lib elsewhere :(
+# No C or C++ is compiled so no SLKCFLAGS here.
+LIBDIRSUFFIX=""
+if [ "$ARCH" = "x86_64" ]; then
+ LIBDIRSUFFIX="64"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/man/man1
+gzip -9c < doc/$PRGNAM.1 > $PKG/usr/man/man1/$PRGNAM.1.gz
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README* COPYING ChangeLog doc/*.py doc/*.md $PKG/usr/doc/$PRGNAM-$VERSION
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/2ping/2ping.info b/network/2ping/2ping.info
new file mode 100644
index 0000000000..168ab6554a
--- /dev/null
+++ b/network/2ping/2ping.info
@@ -0,0 +1,10 @@
+PRGNAM="2ping"
+VERSION="4.1"
+HOMEPAGE="https://www.finnie.org/software/2ping/"
+DOWNLOAD="https://github.com/rfinnie/2ping/archive/v4.1/2ping-4.1.tar.gz"
+MD5SUM="826a626bd8ac85fddaa7f54f87d7fc19"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3"
+MAINTAINER="B. Watson"
+EMAIL="yalhcru@gmail.com"
diff --git a/network/2ping/README b/network/2ping/README
new file mode 100644
index 0000000000..7a2c7f1f07
--- /dev/null
+++ b/network/2ping/README
@@ -0,0 +1,17 @@
+2ping (bi-directional ping utility)
+
+2ping is a bi-directional ping utility. It uses 3-way pings (akin to
+TCP SYN, SYN/ACK, ACK) and after-the-fact state comparison between a
+2ping listener and a 2ping client to determine which direction packet
+loss occurs.
+
+If you would like to quickly test 2ping against a remote listener
+without setting one of your own up, there are several public test
+listeners available. Try test.2ping.net, cromulent.colobox.com, or
+linode-london.mirrors.finnix.org.
+
+To run a listener, you can manually start one with e.g. "2ping --listen".
+If you want to start a listener at boot, add a command like this to
+/etc/rc.d/rc.local:
+
+su nobody -s /bin/sh -c 'exec /usr/bin/2ping --quiet --listen' &> /dev/null &
diff --git a/network/2ping/slack-desc b/network/2ping/slack-desc
new file mode 100644
index 0000000000..f7f97606a1
--- /dev/null
+++ b/network/2ping/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+2ping: 2ping (bi-directional ping utility)
+2ping:
+2ping: 2ping is a bi-directional ping utility. It uses 3-way pings (akin to
+2ping: TCP SYN, SYN/ACK, ACK) and after-the-fact state comparison between
+2ping: a 2ping listener and a 2ping client to determine which direction
+2ping: packet loss occurs.
+2ping:
+2ping:
+2ping:
+2ping:
+2ping: