summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author Philip Lacroix2015-12-20 18:09:25 +0100
committer Willy Sudiarto Raharjo2015-12-20 18:09:25 +0100
commit6f8845c2a5b1304373d2b9049707bbbcf60fbfd4 (patch)
treeac26dc2b3d59e158ad1e51bed1ee8e1dd705369b /network
parentf8ec7ff8d7dc01ba6cde5a7a976d1138ee8732e0 (diff)
downloadslackbuilds-6f8845c2a5b1304373d2b9049707bbbcf60fbfd4.tar.gz
network/bottle: Removes python3 support.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/bottle/bottle.SlackBuild8
1 files changed, 2 insertions, 6 deletions
diff --git a/network/bottle/bottle.SlackBuild b/network/bottle/bottle.SlackBuild
index abe47cf5db..66713c749f 100644
--- a/network/bottle/bottle.SlackBuild
+++ b/network/bottle/bottle.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=bottle
VERSION=${VERSION:-0.12.8}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -47,6 +47,7 @@ mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvzf $CWD/$PRGNAM-$VERSION.tar.gz
+
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -57,11 +58,6 @@ find -L . \
python setup.py install --root=$PKG
-# Python 3 support.
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
-
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" \
| grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true